Jump to content
NotebookTalk

If your MSI notebook has micro-stutters or mouse-pointer-freezes, try this.


Prototime
 Share

Recommended Posts

Below is a copy of a guide I originally posted to NBR on Dec. 2, 2016; last edited July 22, 2017. I hope MSI owners continue to find it useful.
-----------------------------------------------
A common problem for owners of the new "VR-ready" MSI notebooks with Pascal GPUs is micro-stuttering/mouse-pointer-freezing. It's been discussed in multiple owner's lounges, and so far, there is no one-size-fits-all solution. But thanks to a collaborative effort of several MSI notebook owners, a number of fixes have been identified--and more continue to be discovered.

Instead of only discussing this problem across multiple owner's lounges, where owners may come up with solutions that others are less likely to see, let's centralize the conversation here and share what we've learned!

Here's what we've discovered so far in the MSI GS43VR Phantom Pro Owner's Lounge. Please feel free to contribute anything missed here.

First off, if your laptop has Optimus, try going into the Nvidia Control Panel and setting your preferred GPU to to "High-performance NVIDIA processor", then reboot and see if your stuttering issue is gone. If so, congratulations! This has been enough of a fix for some users. If not, or if you don't wish to always have your computer preferring the dGPU, carry on with the rest of this post.

What causes the micro-stutters/mouse-pointer-freezes?
While we can't be entirely certain, the most likely cause is high Deferred Procedure Call (DPC) Latency. Here's a brief explanation of DPC Latency from @PMF, which includes some additional links if you'd like to read more:
 
PMF said: 
Essentially, some drivers can misbehave and hog the CPU's attention, causing other things, especially those that need real-time attention (mouse movements, audio, drawing frames), to be delayed and cause stuttering.

You can google dpc latency, or check out these links directly:
http://www.sweetwater.com/sweetcare/articles/solving-dpc-latency-issues/
http://eu.battle.net/forums/en/d3/topic/5208515698

But my micro-stuttering/mouse-pointer-freezing seems to be Optimus related; it happens only when the iGPU/dGPU switch.

Most owners experience this issue when the iGPU/dGPU switch, and some experience it at other times. (You can tell that your dGPU turns on when your power light color turns yellow). Here's an explanation from @PMF of how DPC Latency and Optimus may interact to cause the stuttering:
 
PMF said: 
To the argument that Optimus appears to be turning off/on with the stuttering, although this is pure speculation: it may be the case that the trigger for Optimus to switch to NVidia is when the Intel card is not handling the load, and in turn, it may be the case that the high DPC latency is causing the system to *think* that the Intel card is not handling the load, and switching to NVidia. Definitely very hard to nail down issues like this though. And there's all kinds of interplay between drivers possible too.

How do I measure DPC Latency?

You can download and run a program called LatencyMon: http://www.resplendence.com/latencymon

Run this program for about 30-60 minutes, and see if any error messages come up indicating that your system may have difficulty handling real-time audio. Also click on the "Drivers" tab to see which drivers have the highest Execution Time. One or more of these drivers may be the culprit.

Oftentimes, but not always, an offending driver may be "ndis.sys", which is the Network Driver Interface Specification (NDIS), and is the driver for your network card. For example, @spaceray noticed he had terrible micro-stuttering when he was on wireless internet, but when he disabled his wireless and used the Ethernet port, the micro-stuttering went away. He then ran LatencyMon and saw that the Highest Execution Time for ndis.sys was 5468.120370 ms when on Ethernet, but skyrocketed to 273534.716821 ms when on wireless. This indicated pretty clearly his micro-stuttering was being caused by his Killer Wireless.

Sometimes, it's clear what device uses a driver--like ndis.sys being used by your network card--but it's not always. For example, on my computer, LatencyMon showed that Wdf01000.sys has a high Execution Time, but there's no easy way to figure out which devices may be using this driver (and it can vary).


How do I resolve the issue micro-stuttering/mouse-pointer-freezing?

As I said before, there isn't a one-size-fits-all solution. But here are some things you can try - most of which involve experimenting with various device drivers.
  1. Run LatencyMon to identify which drivers have the highest Execution Times and DPC Counts.
  2. Try to identify which device uses the driver (using either the info LatencyMon gives about the driver, or Google search the driver name). See if the device's drivers are outdated. If they are, download the latest drivers for the device. You can get them typically from the manufacturer's website, or by going into your Device Manager, right-clicking on the device, and clicking "Update Driver Software."
  3. If that doesn't resolve the micro-stuttering, go into your Device Manager (for Windows 10, right-click the Start button, and then click "Device Manager") and disable that device, assuming it's not something critical. Reboot and see if micro-stuttering is still there.
    • If the micro-stuttering is completely gone, then you've identified the device whose driver is responsible for your stuttering. To prevent future stuttering, you can:
    • Simply keep the device disabled. But this would then prevent you from using the device.
    • Double-check that you have the latest driver version. This might not work, however.
    • Try rolling back to a prior driver version (which again, you may be able to get from the device manufacturer's website). You can try experimenting with various prior versions to see if you find one that resolves the stutter. This still might not work, however.
    • Simply uninstall the driver (via the Device Manager). This might make the device unusable, but there might also be other default device drivers that will take over in their absence. (You can pretty quickly figure this out depending on whether the device still works or not after you uninstall the driver. If it doesn't work anymore, you can always re-install the driver to make it work again). You might lose some functionality using default drivers, but it might be a pretty minor loss, especially in comparison to bad stuttering. Note that Windows Update may try to force the previous non-default driver back onto your computer; if so, see this workaround: http://forum.notebookreview.com/thr...os-owners-lounge.793376/page-47#post-10344748
    • Keep looking out for new driver updates from the manufacturer; a future driver version may get rid of the stutter. @SirGadden reported that an ELAN driver update (which he received through Windows Update) resolved his stuttering issue. Note that not every device will receive driver updates through Windows Update, so you may have to hunt down new driver versions from the device manufacturer's website.
  • If the micro-stuttering is still there but is occurring less, then you've identified one device whose driver may be responsible for your stutter. Repeat steps 2-3 for other drivers that LatencyMon identifies as having a high Execution Time.
  • If the micro-stuttering hasn't changed, then you haven't identified the responsible driver. Repeat step 2-3 for other drives that LatencyMon identifies as having a high Execution Time.
Note about the Killer Wireless Card Adapter: Killer Wireless seems to be a common culprit for several owner's micro-stuttering woes (although it's not always the cause, as @whirledpeas can attest to). Especially if LatencyMon identifies ndis.sys as having high Execution Time (although you might want to try out this tip out this regardless of what LatencyMon says) - try what @spaceray did. Disable your wireless card in the Device Manager, reboot, and plug in Ethernet. Then see if your micro-stuttering issue has been resolved. If so, you can either (1) connect to the internet via an Ethernet cable in the future and keep your wireless disabled (obviously not ideal), or (2) switch out your Killer Wireless Card for an Intel Wireless Card, like @spaceray did (and successfully resolved his issue). I personally had my reseller swap out the stock Killer Wireless Card for an Intel Wireless 8260 card when I bought my GS43VR, and I've been one of the lucky few to have hardly any micro-stuttering. If neither of the above two options sound appealing to you, you can try (3) downloading prior or different Killer driver versions, or (4) keeping your Killer drivers up to date in hopes that a future driver will eventually fix it.

Note: Even if your ndis.sys driver has high DPC latency, there's no guarantee that swapping the wireless card will fix your stuttering issue, and it certainly hasn't worked for every user that's tried it, but multiple users have reported that swapping cards has worked. Thankfully Intel 8260 cards are relatively cheap ($15 USD or so), but it's still a potential solution that involves spending some money, and there's some risk it won't work. I personally think if you're having terrible stuttering issues, it's money well spent, but obviously it's up to you.


If you tried the above steps 1-3 and they didn't work, then you may have to start throwing everything at the wall and seeing what sticks. Here are some other options:
  • Make sure all of your computer's device drivers are up to date, in hopes that an updated driver will fix the problem.
  • Try updating the BIOS; a fix might eventually come through a BIOS update
  • Try experimenting with disabling devices in your Device Manager, one by one, to see if you can identify the culprit. This obviously will take some time.
  • Alternatively (or additionally) to the last suggestion, just start uninstalling various drivers - you might eventually identify the culprit this way, too.
  • If you're up for it, you can also try rolling back to Windows 7; Windows 7 drivers may, at least for some devices, cause lower DPC Latency than Windows 10 drivers.

*Shortcuts to possible solutions: With all these principles in mind, here is a list of various solutions that other users have found worked for them. This list was originally compiled by @hmscott and later supplemented by me. If steps 1-3 don't work, or if you'd rather take a scatter-shot approach, you can try simply going down this list and seeing if anything works for you.
Prototime said: 
[A] number of different workarounds on the microstuttering issue have come up - some work for some owners, others don't. @hmscott compiled a list of posts of workarounds in another thread, which I've supplemented below with some additional workarounds:

--
One user came up with a workaround to keep the 1060 dGPU active all the time so as to stop the microstutters. Another user came up with a similar solution:
http://forum.notebookreview.com/threads/msi-gs43vr-phantom-pros-owners-lounge.793376/#post-10345154
http://forum.notebookreview.com/thr...os-owners-lounge.793376/page-47#post-10345305


Another user mentioned doing 3 things: (1) Using the Nvidia Control Panel, setting the dGPU ("High-performance Nvidia processor") as the preferred GPU, (2) setting certain applications to preferably work with the dGPU, and (3) installing Windows 7 Ultimate 64-Bit:
http://forum.notebookreview.com/posts/10349132/


Another user said that simply using Windows 7 instead of Windows 10 gets rid of the microstutter:
http://forum.notebookreview.com/posts/10349152/


Another user, who kept Windows 10, was helped by (1) using the Nvidia Control Panel to set the dGPU as the preferred GPU, and (2) setting it to maximum performance:
http://forum.notebookreview.com/posts/10349354


An earlier solution was to uninstall the Elan touchpad drivers and use the Microsoft generic drivers (but Windows 10 automatically reinstalls the Elan driver):
http://forum.notebookreview.com/thr...os-owners-lounge.793376/page-47#post-10344723

To help the Elan driver from automatically reinstalling, another user posted a solution to stop Windows 10 driver updates:
http://forum.notebookreview.com/thr...os-owners-lounge.793376/page-47#post-10344748


Another workaround uses NVI (Nvidia Inspector):
http://forum.notebookreview.com/thr...ros-owners-lounge.793376/page-3#post-10344237
http://forum.notebookreview.com/thr...os-owners-lounge.793376/page-46#post-10344255


And an owner got rid of stuttering by uninstalling Nahimic:
http://forum.notebookreview.com/thr...vr-owners-lounge.795277/page-21#post-10347286

Lastly, you can always report this issue to MSI Support. The more people who raise it with them, the better likelihood that they can help fix this through a BIOS update or otherwise.

I hope that all of this information is helpful. Many thanks to the many owners who have offered their insights and time trying to overcome this annoying issue; this thread is merely a summary of what has been a collective effort. I am by no means an expert, and if anything above is incorrect, please feel free to point that out. Additionally, if you have come across any other solutions, or have any other ideas about the problem or how to fix it, please do share!
 
  • Thumb Up 1
  • Thanks 1

Samsung Notebook 9 Pro 15" NP940X5N - 15.0" 1080p IPS glossy touchscreen | Intel Coffeelake i7-8550U CPU | AMD Radeon 540 GPU with 2GB GDDR5 VRAM | 16GB Dual Channel DDR4 RAM | 256GB SSD | Intel Wireless AC 8625 | S Pen

MSI GS43VR 6RE Phantom Pro - 14" 1080p IPS matte screen | Intel Skylake i7-6700HQ CPU | nVidia Pascal GTX 1060 GPU with 6GB GDDR5 VRAM | 16GB Dual Channel DDR4 2400MHz RAM | 500GB Samsung 850 Evo M.2 SSD | 1TB Samsung 860 Evo 2.5" SSD | Intel Wireless AC 8260 | Thunderbolt 3 port | IC Diamond Thermal Compound on CPU + GPU

Link to comment
Share on other sites

  • 1 year later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Terms of Use