Jump to content
NotebookTalk

Alienware Area 51m R2 and EGPU


Recommended Posts

Why is it that the Alienware area 51m R2 is only compatible with AMD GPU when i use external GPU. 

 

I tested the SONNET PUCK RX 5700 and a Devil Box with RX 5700 XT.

 

When I plug in the ROG STRIX RTX 3090 , it blue screen with " DMA VIOLATION " message

 

Update: I believe that Alienware blacklist RTX GPUs. Ran the RX 6900 XT, picture below with zero issues. 

 

20221216_164707.jpg

20221216_170105.jpg

 

GPU: Asrock RX 6900 XT LC 16GB OEM

EGPU: PowerColor Devil Box

PSU: SFX 850 Watts Platinum Grade

Link to comment
Share on other sites

The R2 supports Alienware Graphics Amplifier, which is probably the best way to use eGPU for that system. 

 

However, I've had RX 6800, Titan V, RTX 2080Ti, RTX 3070, and RTX 3090 working in eGPU on my Alienware Area-51m R1 using Alienware Graphics Amplifier. 

 

I've also ran 1080Ti/RTX 3070 using Razer Core X. 

 

Maybe the eGPU enclosure you're using doesn't play well with the R2. Or might need to reinstall drivers using DDU 

Alienware Area-51M : Intel Core i9-9900K @ 5.3Ghz    | nVidia GeForce RTX 2080    | AX210 | Samsung 970 Evo+ 
Alienware X14 R1 :       Intel Core i7 12700H 12th-Gen   | nVidia GeForce RTX 3060    | AX411 | SK Hynix 2TB PCIe4 
Alienware M18x R2 :    Intel Core i7 3920XM @ 4.7Ghz | nVidia Quadro RTX 3000     | AX210 | Samsung 980 PRO   
Alienware 18 R1 :          Intel Core i7 4930MX @ 4.0Ghz | nVidia Quadro RTX 3000     | AX210 | SK Hynix 1TB NVMe 
Clevo X170SM-G:         Intel Core i7 10700K @ Stock     | nVidia GeForce RTX 2070S | AX210 | 256GB+2x512GB 


CS Studios YouTube: https://www.youtube.com/c/CSStudiosYT 

Link to comment
Share on other sites

I recall reports of people using 2 eGPUs in AGA AW machines. Just a wild guess: perhaps you were running AW Nvidia drivers? I would try the latest directly from NV. Can't think of a reason why this wouldn't work other than some dodgy drivers or AW cancerware.

Link to comment
Share on other sites

  • 2 weeks later...

I personally have the Area-51m and I am currently running an Akitio Node Titan eGPU enclosure with an AMD Sapphire NITRO+ 6900xt with zero issues. Yes there is a bandwidth limitation vs the alienware graphics amplifier however the 6900xt doesn't exactly fit in the AGA. There have been rumors of alienware coming out with a new liquid cooled eGPU enclosure called concept polaris but no word on when it will release. I do plan on switching to the newer 7900xtx when sapphire releases its toxic version in the next month. I can easily play 4k 120hz with asus rog XG438q in HDR. I choose to go with the Akitio Node Titan over the Razer variants and alienware eGPU due to the fact of it having a 650w psu and can fit very large air cooled cards. Hope this information can be useful to you. Driver setup was very easy as well. I am sure you can run a 4090 if you wanted to with this setup you may have to get a different psu of connectors but it is possible. Here is a link to the one I am using: https://www.akitio.com/expansion/node-titan

Link to comment
Share on other sites

  • 2 weeks later...
On 11/20/2022 at 9:09 PM, Drammar09 said:

I personally have the Area-51m and I am currently running an Akitio Node Titan eGPU enclosure with an AMD Sapphire NITRO+ 6900xt with zero issues. Yes there is a bandwidth limitation vs the alienware graphics amplifier however the 6900xt doesn't exactly fit in the AGA. There have been rumors of alienware coming out with a new liquid cooled eGPU enclosure called concept polaris but no word on when it will release. I do plan on switching to the newer 7900xtx when sapphire releases its toxic version in the next month. I can easily play 4k 120hz with asus rog XG438q in HDR. I choose to go with the Akitio Node Titan over the Razer variants and alienware eGPU due to the fact of it having a 650w psu and can fit very large air cooled cards. Hope this information can be useful to you. Driver setup was very easy as well. I am sure you can run a 4090 if you wanted to with this setup you may have to get a different psu of connectors but it is possible. Here is a link to the one I am using: https://www.akitio.com/expansion/node-titan

 

Actually, Razer Core X also has a 650W PSU, and supports 3-slot wide cards, as opposed to the 2.5 slots supported by the Aktio Node Titan.

 

https://www.razer.com/gaming-egpus/razer-core-x/RC21-01310200-R3U1#specs

 

It does not come with an aesthetic carrying handle though. The Node Titan looks a bit like the G.E.C.K from the Fallout series, pretty cool in my book ;)

Link to comment
Share on other sites

11 hours ago, Etern4l said:

 

Actually, Razer Core X also has a 650W PSU, and supports 3-slot wide cards, as opposed to the 2.5 slots supported by the Aktio Node Titan.

 

https://www.razer.com/gaming-egpus/razer-core-x/RC21-01310200-R3U1#specs

 

It does not come with an aesthetic carrying handle though. The Node Titan looks a bit like the G.E.C.K from the Fallout series, pretty cool in my book 😉

I did a lot of reading before I went with the akitio node titan over the razer core x for a few reasons. They are both very similar but I had read of a lot of issues when using it with the alienware laptops so that is why I choose the akitio. They are both phenomenal products I am really hoping that alienware does release its concept polaris as it would be such an upgrade over the older alienware graphics amplifier. I would of used the amplifier had it had the room to house such large cards without having to cutup or mod its case but the pcie bandwidth would be so much better using that. I guess we will have to see what the future brings to us in hopes of furthering eGPU use on our machines :).

Link to comment
Share on other sites

On 12/5/2022 at 12:55 AM, Drammar09 said:

I did a lot of reading before I went with the akitio node titan over the razer core x for a few reasons. They are both very similar but I had read of a lot of issues when using it with the alienware laptops so that is why I choose the akitio. They are both phenomenal products I am really hoping that alienware does release its concept polaris as it would be such an upgrade over the older alienware graphics amplifier. I would of used the amplifier had it had the room to house such large cards without having to cutup or mod its case but the pcie bandwidth would be so much better using that. I guess we will have to see what the future brings to us in hopes of furthering eGPU use on our machines :).

 

No issues with Razer Core X.

I would be surprised if Alienware came up with something substantial, after all, they want you to keep buying new laptops rather than new GPUs to use with a $300 enclosure. They killed the AGA, instead of refreshing it, for a reason.

Link to comment
Share on other sites

  • 2 weeks later...

OK. So I finally got a high end AMD card in a EGPU. The card runs fine without crashing the laptop or blue screen. 

 

Conclusion , Alienware probably blacklist egpu RTX graphic cards from working or the other thing that I can think of is when you run a RTX in the egpu , it cause conflict with the RTX DGPU that is already running in the laptop. 

 

BTW , I am running an OEM Liquid Cooled Asrock RX 6900 XT, yes .. it's an OEM model. 

Link to comment
Share on other sites

23 hours ago, Rengsey R. H. Jr. said:

OK. So I finally got a high end AMD card in a EGPU. The card runs fine without crashing the laptop or blue screen. 

 

Conclusion , Alienware probably blacklist egpu RTX graphic cards from working or the other thing that I can think of is when you run a RTX in the egpu , it cause conflict with the RTX DGPU that is already running in the laptop. 

 

BTW , I am running an OEM Liquid Cooled Asrock RX 6900 XT, yes .. it's an OEM model. 

I think the eGPU enclosures you are using just suck LOL 

 

I have used Alienware Graphics Amplifier with my Area-51m R1, and a 13 R3, they work with all of the following RTX cards fine:

RTX 3090Ti EVGA FTW3

RTX 3090 KINGPIN

RTX 3080 XC3

RTX 3070 MSI GAMING TRIO X

RTX 2080Ti PNY Blower Style

 

In addition, I have also tested:

AMD RX 6800 

 

All of them work fine.

 

I also tested two RTX GPUs using Razer Core X in Alienware Area-51m R1 and they work fine. 

 

I would try disabling dGPU in device manager and see if that helps 

  • Bump 2

Alienware Area-51M : Intel Core i9-9900K @ 5.3Ghz    | nVidia GeForce RTX 2080    | AX210 | Samsung 970 Evo+ 
Alienware X14 R1 :       Intel Core i7 12700H 12th-Gen   | nVidia GeForce RTX 3060    | AX411 | SK Hynix 2TB PCIe4 
Alienware M18x R2 :    Intel Core i7 3920XM @ 4.7Ghz | nVidia Quadro RTX 3000     | AX210 | Samsung 980 PRO   
Alienware 18 R1 :          Intel Core i7 4930MX @ 4.0Ghz | nVidia Quadro RTX 3000     | AX210 | SK Hynix 1TB NVMe 
Clevo X170SM-G:         Intel Core i7 10700K @ Stock     | nVidia GeForce RTX 2070S | AX210 | 256GB+2x512GB 


CS Studios YouTube: https://www.youtube.com/c/CSStudiosYT 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Terms of Use