Jump to content
NotebookTalk

XPS 17, 'Modern Standby', S3 sleep, and Windows 10/11


Steerpike
 Share

Recommended Posts

Spinning this thread off from a discussion that started in the 'Windows' forum, since it's not specific to windows 11, and seems to be related to most modern laptop designs.  This is the original post that triggered it - Have you upgraded to Windows 11? - Windows - NBR 3.1B (efgxt.net) Item #12, specifically (thanks to user Aaron44126).

From that thread, context being advanced power management settings and the fact these advanced power management settings are largely gone if your laptop has what is called 'Modern standby'.   

Aaron44126 said

Quote

"...there are changes to it in both Windows 10 and Windows 11 if the system supports "modern standby", and pretty much all new laptops do.  Most of the advanced power options are gone in this case.  You can get them back by disabling modern standby, which adds those options back, but then you won't be able to use the "Sleep" function on your system.  (Hibernate still works.)  This Reddit post explains how to do it.

This is the Reddit post - Getting back S3 sleep and disabling modern standby under Windows 10 >=2004 : Dell (reddit.com)

I started reading the Reddit thread but it is very long, and it seems things have changed with various releases of windows, so hard to know what exactly is the situation 'today'.  I'm hoping this thread could be a 'current state' discussion, perhaps specific to the XPS laptops with 11th gen Intel CPUs. 

I've been a long-time user of 'sleep'. I NEVER shut-down / restart my laptop unless forced to do so by updates (or crashes). I have dozens of apps / windows / tabs open all the time, and I just leave the laptop plugged in and 'on'. When I need to travel, I simply put the laptop to 'sleep' (which I believe is "S3 sleep"), and recover from sleep instantly at my destination. If I'm travelling for long enough (like a trip to Europe) the laptop may decide to go into 'hibernate' mode on its own to save battery.  I will occasionally force Hibernate mode immediately (for example if I need to open up the case and replace a battery, or whatever).  

So ... what the hell is 'modern standby' and how does it differ from S3? The reddit article says "I was just tired of Dell and also Microsoft, both forcing you into Modern Standby, which never worked, doesn't work, and will not ever work reliable on Windows, compared to 100% working and reliable S3 (suspend to RAM) sleep." This MS article suggests it is all about 'instant on', and staying connected to the network while 'idle'.  The article also says "Switching between S3 and Modern Standby cannot be done by changing a setting in the BIOS. Switching the power model is not supported in Windows without a complete OS re-install." - though this could be outdated by now. It also says "Microsoft conceptualizes modern sleep as equivalent to traditional S3 sleep, with the added benefit of allowing value-added software activities to run periodically."

When I put my laptop to sleep, I expect it to stay dormant. I don't want it checking for email or doing anything. My laptop 'wakes' from 'sleep' almost instantly already, so I can't see the benefit of speeding this up! 

Even with good-old-fashioned S3 sleep, very rarely my laptop has decided to wake from sleep and this has been a disaster - I open my backpack to find my laptop red-hot from running without ventilation for hours! Hours of researching my 'event log' never uncovered the root cause of this.  Is 'modern standby' going to make this worse?  It seems they designed 'modern standby' for a machine sitting comfortably on your desk at home; not for a laptop with closed lid and stuffed into an insulating backpack! 

From Aaron44126's post, old-fashioned 'hibernate' is still an option if you disable 'modern standby', but S3 sleep is gone. Other than it taking a minute or more, it does the job quite well and is actually more reliable. Is 'hibernate' an option if you keep 'modern standby' in place? 

 

 

Link to comment
Share on other sites

OK, I'll start by saying that I don't know the ins and outs of "modern sleep".  I have a Dell Precision 7560, which is a laptop with an 11th-gen Tiger Lake CPU, so the situation is most likely pretty similar to what it will be like with the XPS system that you're getting.

 

We are similar here in many ways.  I hate to reboot, I keep tons of stuff open.  I have a calendar alert for 1PM every "second Tuesday of the month" when the Microsoft patches drop (I love that they are consistent and prompt with this) and I try to make that the only time that I'm going to need to reboot for the month.  I'm probably successful a bit more than half of the time; sometimes there is something that I need to install or a system issue that requires me to reboot out of band.  If I have another software update that I suspect will need a reboot, I toss it in a folder and install it at the same time that I am doing the Windows patches when that time rolls around.

 

I also use the "maximum processor state" function in Windows to cap the CPU to 99% (...effectively disabling turbo boost) to keep the fans under control, as I discussed in another thread.  I have a sensorimotor OCD problem and find the fan noise to be rather distracting (more so when it ramps up and down, I prefer for it to stay at a consistent level).  When I got the Tiger Lake system and realized that I was going to have to decide between "sleep working" and "ability to set maximum processor state", it was no choice at all.  I disabled sleep and moved on.  So, I haven't played around with "Modern sleep" to see how well it works (but I have heard plenty of people complaining about it).

 

When I need to travel with the laptop (basically between the office and home — but I've been mostly working from home since COVID started so I don't do it that much), I just hibernate it and that has been fine.  When I just need to move the laptop between rooms or something, I shut the lid but don't bother hibernating.

 

The "PlatformAoAcOverride" registry value is what you need to set to disable modern sleep and enable the advanced power options.  It still works with the current version of Windows 10, and also with Windows 11.  You do have to reboot for it to take effect, as I recall, but you certainly don't have to reinstall Windows.

 

(I have no idea why Microsoft decided to remove these advanced power options if modern sleep is available.  I don't see any reason why that would be necessary, for most of them anyway.  Just trying to keep things simple for people...?)

 

Oh.  I'll also mention that the "power slider" function that I mentioned to quickly enable and disable turbo boost has been removed in Windows 11.  (The "maximum power state" value is ignored when the slider is at the far right setting, it will run at 100% regardless of what you have set.)  Well, it's still there, but it has been moved into "Power options" in Settings as a drop-down and you just can't easily access it from a taskbar flyout anymore.  I found a third-party app that basically adds its own icon to the system tray to bring this functionality back.  If you're interested, I'll dig it up.

Dell Precision 7770 (personal) • Dell Precision 7560 (work) • Full specs in spoiler block below
Info posts (Dell) — Dell Precision key postsDell driver RSS feeds • Dell Fan Management — override fan behavior
Info posts (Windows) — Turbo boost toggle • The problem with Windows 11 • About Windows 10 LTSC

Spoiler

Dell Precision 7770 (personal)

  • Intel Core i9-12950HX ("Alder Lake"), 8P+8E
    • 8× P cores ("Golden Cove"): 2.3 GHz base, 5.0 GHz turbo, hyperthreading
    • 8× E cores ("Gracemont"): 1.7 GHz base, 3.6 GHz turbo
  • 128GB DDR5-3600 (CAMM)
  • NVIDIA GeForce RTX 3080 Ti 16GB (DGFF)
  • Storage:
    • 2TB system drive: Samsung 980 Pro, PCIe4
    • 24TB additional storage: 3× Sabrent Rocket 4 Plus 8TB, PCIe4 (Storage Spaces)
  • Windows 10 (Enterprise LTSC 2021)
  • 17.3" 3940×2160 display
  • Intel Wi-Fi AX211 (Wi-Fi 6E + Bluetooth)
  • 93Wh battery
  • IR webcam
  • Fingerprint reader

 

Dell Precision 7560 (work)

  • Intel Xeon W-11955M ("Tiger Lake")
    • 8×2.6 GHz base, 5.0 GHz turbo, hyperthreading ("Willow Cove")
  • 64GB DDR4-3200 ECC
  • NVIDIA RTX A2000 4GB
  • Storage:
    • 512GB system drive (Micron 2300)
    • 4TB additional storage (Sabrent Rocket Q4)
  • Windows 10 (Enterprise LTSC 2021)
  • 15.6" 3940×2160 display
  • Intel Wi-Fi AX210 (Wi-Fi 6E + Bluetooth)
  • 95Wh battery
  • IR webcam
  • Fingerprint reader

 

Previous

  • Dell Precision 7530, 7510, M4800, M6700
  • Dell Latitude E6520
  • Dell Inspiron 1720, 5150
  • Dell Latitude CPi
Link to comment
Share on other sites

15 hours ago, Aaron44126 said:

...

I have a sensorimotor OCD problem and find the fan noise to be rather distracting (more so when it ramps up and down, I prefer for it to stay at a consistent level). 

 

I don't know if my situation has a 'name' or not, but I've always been hyper-sensitive to noise. I prefer to drive in silence, only playing music if I really want to listen to something in particular. I find 'background music' to be totally distracting and makes me feel stressed. When I had desktop PCs at home, I went to great lengths to silencing them - underclocking, soundproofing, fan controls, etc!

Quote

When I got the Tiger Lake system and realized that I was going to have to decide between "sleep working" and "ability to set maximum processor state", it was no choice at all.  I disabled sleep and moved on.  So, I haven't played around with "Modern sleep" to see how well it works (but I have heard plenty of people complaining about it).

When I need to travel with the laptop (basically between the office and home — but I've been mostly working from home since COVID started so I don't do it that much), I just hibernate it and that has been fine.  When I just need to move the laptop between rooms or something, I shut the lid but don't bother hibernating.

The "PlatformAoAcOverride" registry value is what you need to set to disable modern sleep and enable the advanced power options.  It still works with the current version of Windows 10, and also with Windows 11.  You do have to reboot for it to take effect, as I recall, but you certainly don't have to reinstall Windows.

So you have disabled 'modern sleep', which re-enables advanced power options. Does this not also restore original 'S3' sleep, and if so, is there a reason you don't use S3 sleep when traveling? Or is S3 sleep completely gone now? I guess with BIOS support for it being removed, it's no longer an option under any circumstances.  I can live with hibernate - it just takes a bit longer but such is life. Are these 'advanced power options' still reached through Control Panel / Power ...?  

Do you still get to say what happens on lid-close? Ironically I always used to set it to 'do nothing' anyway, and it sounds like that's what you've done. 

Quote

 

(I have no idea why Microsoft decided to remove these advanced power options if modern sleep is available.  I don't see any reason why that would be necessary, for most of them anyway.  Just trying to keep things simple for people...?)

Oh.  I'll also mention that the "power slider" function that I mentioned to quickly enable and disable turbo boost has been removed in Windows 11.  (The "maximum power state" value is ignored when the slider is at the far right setting, it will run at 100% regardless of what you have set.)  Well, it's still there, but it has been moved into "Power options" in Settings as a drop-down and you just can't easily access it from a taskbar flyout anymore.  I found a third-party app that basically adds its own icon to the system tray to bring this functionality back.  If you're interested, I'll dig it up.

If 'modern sleep' worked flawlessly I may accept it - while I don't want or need windows to be waking all the time and updating things like emails, updates, etc if it 'just worked' I'd accept it, but my experience with even the more robust old 'S3' sleep was that certain unexpected events would wake up the laptop, and do so at the worst possible times, and not go back to sleep (it might have been some form of USB wake events triggering incorrectly). With windows being such an 'open' system, they can't easily control what rogue / incompetent 3rd parties do, and I can see all manner of problems arising. There's talk in that Reddit thread that laptops have caught fire due to this.  Philosophically, it always bugged me that my Macs were constantly waking and checking for stuff. When I 'sleep' my laptop, I expect it to sleep!  

It's also interesting that you are able to stop your fans with max processor state of 99, while for me I had to use 70 before silence prevailed. In your case, it was just a matter of killing turbo, but for me, obviously, it was more. This of course could be due to my laptop being older (2014). 

Thanks for the details!  I feel better now about my soon-to-arrive laptop! 

  • Thumb Up 1
Link to comment
Share on other sites

35 minutes ago, Steerpike said:

Thanks for the details!

Hitting some of your points.

  • I totally get you with the sound thing.  I can work with music going either.  Don't get me started on sound + sleep...
  • I believe the registry change to disable "modern sleep" will then enable "S3 sleep" if the system supports it.  However, the Precision 7560 does not support it.  In this case, in Windows, the "sleep" option is completely gone.
  • "Advanced power options" are still in exactly the same place.  (You will just find most of them missing if "modern sleep" is enabled.)
  • I do indeed have the system set to "do nothing" on lid close.
  • Setting the max processor state to 99% does not stop the fans.  It disables the turbo boost and prevents the fans from ramping up to a high level when doing light work like browsing, office work, etc. which is what I am going for.  I'm fine with the fans staying on if they maintain a constant, low level and don't cycle on and off.  I actually have a program that I run on my Precision M6700 to "lock" the fans at the lowest level (≈2600 RPM) unless the CPU temperature gets too high.
  • Incidentally, on my Precision 7560 with turbo boost disabled (max processor state set to 99%), the BIOS/EC runs the fans between 900 and 1600 RPM.  I cannot hear the fans at all until they hit around 1900 RPM.  So it's effectively silent.  I love this new setup they have going with the fans on Tiger Lake systems; the control from the BIOS is much more granular than before.  Previous Dell laptops that I have used had no fan value between mid-2000's RPM and "off" so I would always hear it if the fans turned on.

Dell Precision 7770 (personal) • Dell Precision 7560 (work) • Full specs in spoiler block below
Info posts (Dell) — Dell Precision key postsDell driver RSS feeds • Dell Fan Management — override fan behavior
Info posts (Windows) — Turbo boost toggle • The problem with Windows 11 • About Windows 10 LTSC

Spoiler

Dell Precision 7770 (personal)

  • Intel Core i9-12950HX ("Alder Lake"), 8P+8E
    • 8× P cores ("Golden Cove"): 2.3 GHz base, 5.0 GHz turbo, hyperthreading
    • 8× E cores ("Gracemont"): 1.7 GHz base, 3.6 GHz turbo
  • 128GB DDR5-3600 (CAMM)
  • NVIDIA GeForce RTX 3080 Ti 16GB (DGFF)
  • Storage:
    • 2TB system drive: Samsung 980 Pro, PCIe4
    • 24TB additional storage: 3× Sabrent Rocket 4 Plus 8TB, PCIe4 (Storage Spaces)
  • Windows 10 (Enterprise LTSC 2021)
  • 17.3" 3940×2160 display
  • Intel Wi-Fi AX211 (Wi-Fi 6E + Bluetooth)
  • 93Wh battery
  • IR webcam
  • Fingerprint reader

 

Dell Precision 7560 (work)

  • Intel Xeon W-11955M ("Tiger Lake")
    • 8×2.6 GHz base, 5.0 GHz turbo, hyperthreading ("Willow Cove")
  • 64GB DDR4-3200 ECC
  • NVIDIA RTX A2000 4GB
  • Storage:
    • 512GB system drive (Micron 2300)
    • 4TB additional storage (Sabrent Rocket Q4)
  • Windows 10 (Enterprise LTSC 2021)
  • 15.6" 3940×2160 display
  • Intel Wi-Fi AX210 (Wi-Fi 6E + Bluetooth)
  • 95Wh battery
  • IR webcam
  • Fingerprint reader

 

Previous

  • Dell Precision 7530, 7510, M4800, M6700
  • Dell Latitude E6520
  • Dell Inspiron 1720, 5150
  • Dell Latitude CPi
Link to comment
Share on other sites

Just received my new XPS 17.  Very nice :).  I've decided to try using it 'as delivered' for now, to see how it goes, before making changes. 

To my surprise, without changing anything, I have 'advanced power options' available, and I'm in 'modern standby' mode. Specifically, I can go to control panel, power options, change plan settings, change advanced power settings - and there I see 'Processor Power Management', and I can set % values for both battery and plugged in.  I may have misunderstood, but I thought these options were not available with modern standby. 

I was also able to enable Hibernate mode, and now have hibernate available as a power option along with sleep and shutdown. BUT - while I can still set a sleep time, I cannot find a way to specify a hibernate time - that is, I can say, 'sleep after 30 minutes' but I can't say 'hibernate after 4 hours' - which I have setup on my current system. So if I just let it go to sleep and ignore it, it will never transition to hibernate mode, which sucks. 

  • Thumb Up 1
Link to comment
Share on other sites

36 minutes ago, Steerpike said:

To my surprise, without changing anything, I have 'advanced power options' available, and I'm in 'modern standby' mode. Specifically, I can go to control panel, power options, change plan settings, change advanced power settings - and there I see 'Processor Power Management', and I can set % values for both battery and plugged in.  I may have misunderstood, but I thought these options were not available with modern standby.

Nice, maybe they corrected this "issue" in Windows 11 ...... I have not checked that specifically.

Dell Precision 7770 (personal) • Dell Precision 7560 (work) • Full specs in spoiler block below
Info posts (Dell) — Dell Precision key postsDell driver RSS feeds • Dell Fan Management — override fan behavior
Info posts (Windows) — Turbo boost toggle • The problem with Windows 11 • About Windows 10 LTSC

Spoiler

Dell Precision 7770 (personal)

  • Intel Core i9-12950HX ("Alder Lake"), 8P+8E
    • 8× P cores ("Golden Cove"): 2.3 GHz base, 5.0 GHz turbo, hyperthreading
    • 8× E cores ("Gracemont"): 1.7 GHz base, 3.6 GHz turbo
  • 128GB DDR5-3600 (CAMM)
  • NVIDIA GeForce RTX 3080 Ti 16GB (DGFF)
  • Storage:
    • 2TB system drive: Samsung 980 Pro, PCIe4
    • 24TB additional storage: 3× Sabrent Rocket 4 Plus 8TB, PCIe4 (Storage Spaces)
  • Windows 10 (Enterprise LTSC 2021)
  • 17.3" 3940×2160 display
  • Intel Wi-Fi AX211 (Wi-Fi 6E + Bluetooth)
  • 93Wh battery
  • IR webcam
  • Fingerprint reader

 

Dell Precision 7560 (work)

  • Intel Xeon W-11955M ("Tiger Lake")
    • 8×2.6 GHz base, 5.0 GHz turbo, hyperthreading ("Willow Cove")
  • 64GB DDR4-3200 ECC
  • NVIDIA RTX A2000 4GB
  • Storage:
    • 512GB system drive (Micron 2300)
    • 4TB additional storage (Sabrent Rocket Q4)
  • Windows 10 (Enterprise LTSC 2021)
  • 15.6" 3940×2160 display
  • Intel Wi-Fi AX210 (Wi-Fi 6E + Bluetooth)
  • 95Wh battery
  • IR webcam
  • Fingerprint reader

 

Previous

  • Dell Precision 7530, 7510, M4800, M6700
  • Dell Latitude E6520
  • Dell Inspiron 1720, 5150
  • Dell Latitude CPi
Link to comment
Share on other sites

1 hour ago, Steerpike said:

...

I was also able to enable Hibernate mode, and now have hibernate available as a power option along with sleep and shutdown. BUT - while I can still set a sleep time, I cannot find a way to specify a hibernate time - that is, I can say, 'sleep after 30 minutes' but I can't say 'hibernate after 4 hours' - which I have setup on my current system. So if I just let it go to sleep and ignore it, it will never transition to hibernate mode, which sucks. 

Did some more digging, and this forum post worked for me, in terms of restoring the 'hibernate after ...' setting! 

Specifically, I opened the referenced registry key, and changed the already present DWORD from 0 to 2, rebooted, and now I can see 'hibernate after'. I'm going to set it to a short value and see if it works or not ... 

Quote

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\238C9FA8-0AAD-41ED-83F4-97BE242C8F20\9d7815a6-7ee4-497e-8888-515a05f02364

Attributes DWORD

1 = Remove
2 = Add

 

  • Thumb Up 1
Link to comment
Share on other sites

  • 6 months later...
Disabling the modern standby (S0) and enabling the classic sleep mode (S3) is pretty tricky, but possible.
 
First of all, you need to disable the S0 standby mode by adding a registry key. After a reboot there will be no sleep option available. That's because Dell decided to disable S3. To resolve this issue, you will need to enable the ACPI S3 Support in the BIOS.
 
Unfortunately, this setting is hidden by default, but you can change it in a similar way as it is shown here. You need to find the "ACPI S3" setting and determine it's offset.
 
Once you turn this feature using a command like "setup_var Setup 0x0E 0x1" (offset will be different in your case), you will see the sleep mode again, there will be S3 states available (powercfg /a), but it wouldn't work properly.
 
I suggest switching the SSD mode from Raid On to AHCI and update drivers. It should help resolving this issue.
Link to comment
Share on other sites

10 hours ago, TwistedAndy said:
Disabling the modern standby (S0) and enabling the classic sleep mode (S3) is pretty tricky, but possible.
 
First of all, you need to disable the S0 standby mode by adding a registry key. After a reboot there will be no sleep option available. That's because Dell decided to disable S3. To resolve this issue, you will need to enable the ACPI S3 Support in the BIOS.
 
Unfortunately, this setting is hidden by default, but you can change it in a similar way as it is shown here. You need to find the "ACPI S3" setting and determine it's offset.
 
Once you turn this feature using a command like "setup_var Setup 0x0E 0x1" (offset will be different in your case), you will see the sleep mode again, there will be S3 states available (powercfg /a), but it wouldn't work properly.
 
I suggest switching the SSD mode from Raid On to AHCI and update drivers. It should help resolving this issue.

It seems like your final conclusion is "but it wouldn't work properly" so - despite the fact you can make all these changes, it seems like it doesn't work - correct? 

Link to comment
Share on other sites

It works, Windows reports that S3 is available, the sleep mode is there, but there's an issue with waking up. The laptop freezes on the Dell logo.

 

From what I've found this problem is related to the Raid mode enabled in BIOS. In this mode the system is using Intel's AHCI driver (part of IRST). Switching to AHCI in BIOS solves it, but requires some additional manipulation with the system bootloader and drivers.

 

I'm too lazy to go that far 🙂

Link to comment
Share on other sites

22 hours ago, TwistedAndy said:

It works, Windows reports that S3 is available, the sleep mode is there, but there's an issue with waking up. The laptop freezes on the Dell logo.

 

From what I've found this problem is related to the Raid mode enabled in BIOS. In this mode the system is using Intel's AHCI driver (part of IRST). Switching to AHCI in BIOS solves it, but requires some additional manipulation with the system bootloader and drivers.

 

I'm too lazy to go that far 🙂

 

Switching from RAID to AHCI is pretty straight-forward.  You just have to make sure that the system goes to safe mode once right after you make the switch in the BIOS, and Windows will get everything set up right.  Detailed steps:

https://www.nbrchive.net/forum.notebookreview.com/threads/precision-7560-7760-owners-thread.836381/page-64.html#post-11112315

Dell Precision 7770 (personal) • Dell Precision 7560 (work) • Full specs in spoiler block below
Info posts (Dell) — Dell Precision key postsDell driver RSS feeds • Dell Fan Management — override fan behavior
Info posts (Windows) — Turbo boost toggle • The problem with Windows 11 • About Windows 10 LTSC

Spoiler

Dell Precision 7770 (personal)

  • Intel Core i9-12950HX ("Alder Lake"), 8P+8E
    • 8× P cores ("Golden Cove"): 2.3 GHz base, 5.0 GHz turbo, hyperthreading
    • 8× E cores ("Gracemont"): 1.7 GHz base, 3.6 GHz turbo
  • 128GB DDR5-3600 (CAMM)
  • NVIDIA GeForce RTX 3080 Ti 16GB (DGFF)
  • Storage:
    • 2TB system drive: Samsung 980 Pro, PCIe4
    • 24TB additional storage: 3× Sabrent Rocket 4 Plus 8TB, PCIe4 (Storage Spaces)
  • Windows 10 (Enterprise LTSC 2021)
  • 17.3" 3940×2160 display
  • Intel Wi-Fi AX211 (Wi-Fi 6E + Bluetooth)
  • 93Wh battery
  • IR webcam
  • Fingerprint reader

 

Dell Precision 7560 (work)

  • Intel Xeon W-11955M ("Tiger Lake")
    • 8×2.6 GHz base, 5.0 GHz turbo, hyperthreading ("Willow Cove")
  • 64GB DDR4-3200 ECC
  • NVIDIA RTX A2000 4GB
  • Storage:
    • 512GB system drive (Micron 2300)
    • 4TB additional storage (Sabrent Rocket Q4)
  • Windows 10 (Enterprise LTSC 2021)
  • 15.6" 3940×2160 display
  • Intel Wi-Fi AX210 (Wi-Fi 6E + Bluetooth)
  • 95Wh battery
  • IR webcam
  • Fingerprint reader

 

Previous

  • Dell Precision 7530, 7510, M4800, M6700
  • Dell Latitude E6520
  • Dell Inspiron 1720, 5150
  • Dell Latitude CPi
Link to comment
Share on other sites

I have tried that again, S3 is available and enabled, but pretty buggy:

 

image.thumb.png.6e599e7b13b4733ec823ffb192fee79c.png

 

Maybe, there're some other hidden settings in the BIOS, but I don't have much time to do a further research. Switching to AHCI does not solve all the issues. For now I decided to stay with the S0 since it is much more "polished".

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Terms of Use