Jump to content
NotebookTalk

Need help unbricking Lenovo Flex 3 1580


K4sum1
 Share

Recommended Posts

I have asked for help with this before on other sites, and haven't gotten much help. So I'm asking here, since it's the most popular of the two NBR replacements.

I have a Lenovo Flex 3 1580 that I got some time in 2016. Sometime in 2018 I had tried to update the BIOS on it, and it became bricked. It would power on, but nothing would come up on the screen.

Fast forward to late 2021, I bought a CH341A programmer, a Pomona 5250 clip, and some wires, and attempted to use those to flash a BIOS onto the laptop. This went horribly and only corrupted the chip, and the laptop no longer powered on or charged or showed any signs of life.

Fast forward to January 2022, while I was doing research on Thinkpads and Coreboot, I discovered that the Raspberry Pi could flash a BIOS. I have a Raspberry Pi 3 B laying around, so I hooked the clip up to that, and successfully flashed the latest BIOS onto the laptop. However I’m now back to where I began, the laptop powers on but still nothing comes up on screen, except there is one change, USB devices now get power when before the devices got no power.

I kinda gave up at this point, until a couple days ago, I was watching a video by Mark Furneaux where he was fixing a dead server motherboard. He ended up fixing it by downloading the latest BIOS (which was in .cap format) extracting the .cap with UEFITool, and flashing the BIOS onto the chip. Before this, I was extracting the BIOS updater .exe with UniExtract, which gave me a few files, and the BIOS in .cap format, I extracted the .cap with plain 7-zip, and was flashing the 8MB file simply named 6C60EE00 onto the chip. Now that I knew it existed, I extracted the .cap with UEFITool, but there was no change.

I asked about this on a few other sites, and didn’t get much help. One response I got was to try a different BIOS version. Lenovo doesn’t list downloads for older versions of it’s software, but something I discovered is that you can get old versions from their servers if you know the name of the file. Trying this out, I got various releases of the laptop’s BIOS, and tried flashing them all, but got the same result, except with one change. If the laptop is on, plugging and unplugging the charger makes a single loud beep. Plugging and unplugging the battery makes a single loud but not as loud beep with a different pitch. The latest BIOS does not have this behavior.

I have three hypotheses on why this might not be working.

1: When extracting the .cap, there are three files, 6C60EE00, FFFFFFFF, and SystemFlashUpdateDriverDxe.efi. I have been flashing just 6C60EE00, but I’m thinking that FFFFFFFF might be important in some way. The BIOS is for like 5 different laptop models, and I’m thinking FFFFFFFF might contain specific information for each laptop. The laptop might not be booting because it can’t figure out what model of laptop it is. Or maybe it just expects to boot SystemFlashUpdateDriverDxe.efi, but I’m not sure. I can’t make any sense of the less than a kilobyte of data in FFFFFFFF so either could be true.

2: When doing a BIOS update on some Lenovo laptops, the BIOS gets flashed, and then the BIOS flashes a embedded controller. Maybe the BIOS flash worked back in 2018, but the flash to the embedded controller failed, and that’s why nothing has worked.

3: In the time between 2018 and now, something, either by me being the big dumb or just time could have broken a component on the board or the display or some other part of the laptop.

Some other things to note

1: The laptop has a 16MB BIOS chip while the BIOS is 8MB. Flashtool complains about this, and to remedy the problem, I have tried both appending 8MB of 0’s to the BIOS, and duplicating the BIOS so it is 16MB. Both are suggested when dealing with this problem with flashtool, but both give me the same result.

2: Removing RAM does not change the behavior.

3: The laptop immediately powers on when it is given power, however from what I’ve seen, this is normal behavior for Lenovo laptops when it has no CMOS data.

4: I can’t find any custom BIOSes or any versions of Coreboot/Libreboot to test, nor can I find any dumps of the laptop’s BIOS from the chip on sites that aren’t a scam. I’m not willing to dump any more money into this laptop anyways.

If you can help me fix this before I go full TechRax on it, I would very much appreciate it.

Thinkpad T430 - i7 3630QM, 16GB RAM, Intel HD 4000, 1080p display mod

Elitebook 8770W - i5 3320M (Temporary), 16GB RAM, GTX 980m (broken)

Main PC - AMD Ryzen 9 5950X, 64GB RAM, RTX 2080 Ti

Link to comment
Share on other sites

  • 7 months later...

https://badcaps.net/forum/showthread.php?t=58326 This link has the bios file . download the bios file in the #3(third) reply and use a bios programmer to flash the bios chip on the motherboard. I used CH341a bios programmer to flash my bios and my yoga 500-15ISK(flex 3-1580) came alive again. Just make sure your motherboard model is LT41_SKL_MB 14292-1 448.06701.0011 which can be found below the ram slot on the motherboard

  • Thanks 1
  • Like 1
Link to comment
Share on other sites

  • 5 weeks later...

The laptop has been working fine for a bit, but I've found that it can end up in a wierd pseudo sleep mode, where it powers on with loud fans that don't slow down, but the light on the side is blinking like sleep mode. The keyboard and trackpad don't work, but the screen and touch does. Ethernet and WiFi doesn't work but USB does. I can power the machine off, but it always stays in this pseudo sleep mode until the battery drains. Also Windows thinks it's plugged in even when not. Also the BIOS button only acts as another power button. Also the screen stays on when shut.

Thinkpad T430 - i7 3630QM, 16GB RAM, Intel HD 4000, 1080p display mod

Elitebook 8770W - i5 3320M (Temporary), 16GB RAM, GTX 980m (broken)

Main PC - AMD Ryzen 9 5950X, 64GB RAM, RTX 2080 Ti

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Terms of Use