Jump to content
NotebookTalk

HELP an old Ranger


IVHOTEP

Recommended Posts

Well a big Helo to  you all, especially all of you I remember from the late notebookreview. Special greetings to all of you that still may remember me=) and to whoever made the wise decision to make an archive.

 

I am a bit older now and had other issues since so instead of going through all that archive I supposed to ask here.

 

I just love this laptop, sure its old but for my purposes its still very good. I love the looks, the feels...all the others I ever saw were just meh, Ill pass..

 

Last time I had trouble with my Ranger was 2020, the amd card went so I got into the upgrade bonanza thing....980m, 120hz, unlocked BIOS, ram, heatsinks, liquid metal, pwm bypass switch, u3 mod cooler and God knows what else.

Knowing I will eventually have to reconstruct my steps I always did some kind of backup files, photos and wrote down a few things but it never seems enough info. I just forget.

All went quite well for 3 years, especially temps, ice cold under all the load  I gave it.

 

Then a year ago I noticed a thin vertical line almost in the right corner of the display. I have an matte N173HHE-G32 REV. C2 one.

Then after a while I think another ones to the left and right far end, after some time another one. Then it BSODed. Crap I thought and went back to the 60hz display after updating gpu driver. Never touched the vbios or anything else since the card, 980m, was installed.

That was all good untill two months ago I got powerdowns, freezes of sort and the thing was dead.

I mean I have tried everything I knew and was able to remember and came to the conclusion the motherboard died.

So I got a new one from USA, about 200 euros, seemed legit, looked good and really unused.

Nice to be able to still source those, took a while since it arrived and I had time to mess with it but..

Put it all back and..voila!...it works!

I was surprised that I did not have to reinstall windows. All was there except office license which I had to pay again.

BIOS is A14. stock one I guess.

All worked fine for a few weeks and then...strange display behavior, lines of all sorts and then black screen. 8 beeps. The display was dead.

I put back the 120 Hz again and it works with only that first vertical line I noticed before.

 

Now here's where I am puzzled...there is no more service TAG. I read somewhere that I had to write it in the bios the first time I powered it on but ofc I didn't.

So that means no more unlocked BIOS!?

No more PEG? But my display works in some weird mode? FnF5  gets me the message in the pic below.

If it is SG dedicated card would fire up when under load? It doesnt. So I need to reinstall gpu drivers?

HW info and bios recognize GForce card but device manager says Basic Microsoft Display Adapter.

Now I don't know where to start, no more 60hz screen for backup and i am afraid I don't mess it up and lose my nerve.

 

So any suggestions will be appreciated!

 

Thanks!

 

1.gif

2.jpg

Link to comment
Share on other sites

@IVHOTEPDo you have any error codes for your video card in Device Manager? maybe she's dying

 

and do you currently have a laptop running in SG mode with a 120 Hz screen?? Do you have two video cards (Intel and Nvidia) displayed in the BIOS and in the device manager in Windows?

 

and do you have any windows 8 fast boot or legacy enabled in boot in bios?

 

if you currently have two video cards displayed, you can try resetting the BIOS settings by removing the CMOS battery (on my 17 I used a negative screwdriver to pry off the battery and insert something paper/cardboard under it and run it without it to hear 5 peaks and next time the laptop will turn on with resetting the BIOS settings). but I’m not sure that this is worth doing, since Legacy mode may turn on and the laptop may refuse to start with a video card inserted into it, and then without it (I have no experience experimenting with a 120 Hz monitor, so I’m not sure), because monitor 120 Hz. You can also flash the unlocked BIOS and enable PEG manually, perhaps I would do this first.

Alienware M18x R2: i7-3920XM @4.7 GHz / 24GB DDR3-1866 /  Quadro P4000 Oc`d

upgraded from: Tesla M6 Oc`d

Alienware M18x R2: i7-3720QM / 16GB DDR3L-1600 /  Quadro M3000M

Alienware 17 R1: i7-4710MQ / 16GB DDR3L-1600 /  Quadro M3000M

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Terms of Use