Jump to content
NotebookTalk

M18x R2 GTX 1080 graphics switching


kenny27
 Share

Recommended Posts

I have an aetina 1080 in M18x, so far it has been running as well as can be expected but, some games run on intergrated graphics most notably witch 3 and NFS16 while others like Crysis 3, Shadow of Mordor and benchmarks run just fine.

I have tried a few different driver versions, laptop power plan is set to high performance, in the nvidia control panel: setting the graphics processor to high performance, cuda cores processor to 1080 and switching power plan between max performance, optimal and adaptive makes no difference.

 

Only things I havent done is change the intel drivers or reinstall games/windows.

 

Has anyone else had this upgrading to a gpu that requires SG graphics and is there another way to force the dedicated gpu to run?

M18x R2 | 3920XM | 16GB DDR3 @ 2133Mhz | 980M SLI | 256GB Samsung 840 Evo + 1TB HHD | Audioengine D1 | Beyordynamic DT990 | Corsair M65

Link to comment
Share on other sites

depending on what OS version youre running, i know they changed the preferred GPU option to be set within the settings panel in the later versions (im running LTSC IoT 2021 which made it so the setting is within windows now instead of nvidia control panel, compared to the previous LTSC version). maybe this is the culprit?

Alienware M18X R2 | Nebula Red | i7 3740QM [OC'd to 4Ghz] | 32GB RAM | NVIDIA Quadro P4000 | 75hz OC'd Display |

MXM to NVMe Adapter with Samsung 970 Evo Plus 2TB

Alienware 17 R4 | i7 6700HQ | 16GB RAM | GTX 1070 | 100hz OC'd LG 1080p Display

Alienware M18X R1 | Space Black | i7 2960XM | 16GB RAM | GTX 780M

 
Link to comment
Share on other sites

Go to your windows settings, search for graphics, there should be a option to choose which GPU to use per app. Add each app that does not use dGPU and select high performance gpu. 

Alienware Area-51M : Intel Core i9-9900K @ 5.3Ghz    | nVidia GeForce RTX 2080    | AX210 | Samsung 970 Evo+ 
Alienware X14 R1 :       Intel Core i7 12700H 12th-Gen   | nVidia GeForce RTX 3060    | AX411 | SK Hynix 2TB PCIe4 
Alienware M18x R2 :    Intel Core i7 3920XM @ 4.7Ghz | nVidia Quadro RTX 3000     | AX210 | Samsung 980 PRO   
Alienware 18 R1 :          Intel Core i7 4930MX @ 4.0Ghz | nVidia Quadro RTX 3000     | AX210 | SK Hynix 1TB NVMe 
Clevo X170SM-G:         Intel Core i7 10700K @ Stock     | nVidia GeForce RTX 2070S | AX210 | 256GB+2x512GB 


CS Studios YouTube: https://www.youtube.com/c/CSStudiosYT 

Link to comment
Share on other sites

On 2/25/2022 at 9:26 PM, Azther said:

depending on what OS version youre running, i know they changed the preferred GPU option to be set within the settings panel in the later versions (im running LTSC IoT 2021 which made it so the setting is within windows now instead of nvidia control panel, compared to the previous LTSC version). maybe this is the culprit?

Yes this works I got the graphic switching part sorted now, pity that the nvidia control panel switching is now completely useless.

Witcher 3 starts on integrated graphics but still not dedicated, NFS16 refuses to start at all, thinking there is something else at play...  just odd that its happened since swapping in the 1080/using SG graphics.

I have no dxdiag errors, removed all mods, 1080 clocks do jump when both are launch and gpu-z sometimes detect power limit... will see what a fresh install of windows will do, I'll outa ideas.

 

M18x R2 | 3920XM | 16GB DDR3 @ 2133Mhz | 980M SLI | 256GB Samsung 840 Evo + 1TB HHD | Audioengine D1 | Beyordynamic DT990 | Corsair M65

Link to comment
Share on other sites

I am having a similar problem with UserBenchMark.exe from https://www.userbenchmark.com/.

When the gpu test comes up it uses integrated and I have set it in windows and Nvidia control panel. There must be a way to stop windows from taking control over Nvidia

Alienware M18x R2 i7-3920xm-16GB DDR3-Quadro P4000  Alienware M17x R4 i7-3940XM 16GB DDR3-1866 Quadro P4000

Precision m6700 i7-3840QM - 16.0GB DDR3 - GTX 970M     Alienware M17x R4 i7-3940XM 32GB DDR3-1600 GTX 680M 120hz 3D
Precision m4700 i7-3610QM-8.00GB DDR3 @ 1600MHz-K2000M

GOBOXX SLM  G2721-i7-10875H RTX 3000-32GB ddr4(Gave to my Wife)

 

Link to comment
Share on other sites

7 hours ago, aldarxt said:

I am having a similar problem with UserBenchMark.exe from https://www.userbenchmark.com/.

When the gpu test comes up it uses integrated and I have set it in windows and Nvidia control panel. There must be a way to stop windows from taking control over Nvidia

Using the windows settings worked for me.... is there a specific application that user bench uses for the gpu test that you could add to the windows gpi priority settings? 

 

Reinstalling the games that didnt work have solved my other crashing issues.

  • Thumb Up 1

M18x R2 | 3920XM | 16GB DDR3 @ 2133Mhz | 980M SLI | 256GB Samsung 840 Evo + 1TB HHD | Audioengine D1 | Beyordynamic DT990 | Corsair M65

Link to comment
Share on other sites

On 3/7/2022 at 11:45 AM, kenny27 said:

Using the windows settings worked for me.... is there a specific application that user bench uses for the gpu test that you could add to the windows gpi priority settings? 

 

Reinstalling the games that didnt work have solved my other crashing issues.

I got it working by setting Preferred Graphics Processor to "High Performance Nvidia Processor" in 3D Settings, Nvidia Control Panel. That program runs through some tests in temp folder and can't set them in windows or Nvidia Control Panel. Just the main .exe can be set. I like running UserBenchMark because it is alot faster than 3DMark and I can change PC settings more quickly to adjust for performance. But your bringing this issue up helped me to figure it out. I didn't know about windows taking control of the GPU, M$FT fingers getting too Sticky!

Alienware M18x R2 i7-3920xm-16GB DDR3-Quadro P4000  Alienware M17x R4 i7-3940XM 16GB DDR3-1866 Quadro P4000

Precision m6700 i7-3840QM - 16.0GB DDR3 - GTX 970M     Alienware M17x R4 i7-3940XM 32GB DDR3-1600 GTX 680M 120hz 3D
Precision m4700 i7-3610QM-8.00GB DDR3 @ 1600MHz-K2000M

GOBOXX SLM  G2721-i7-10875H RTX 3000-32GB ddr4(Gave to my Wife)

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Terms of Use