Jump to content
NotebookTalk

EUROCOM SKY x9c model (p870tm1‐g) added rtx 3080 mxm but no display yet


oops

Recommended Posts

i bought this laptop from eurocom but not at once parts like gpu and cpu were missing then bought them after waited for moded heatsink then unboxed the packages put them together but on my surprise powering on keyboard lights caps lock works but no lights on display and stays black tried changing ram nothing changing am stuck because i was told it should be plug and play before even moded drivers any help please thanks in advance 

IMG_20230328_171133.jpg

IMG_20230328_171125.jpg

Link to comment
Share on other sites

typically its the ram or cmos battery, you can try 1 stick each in different slots to see if it boots(I know you said you tried ram but maybe its just 1 slot) and then you can try a cmos reset. just google cmos reset for your model. if this doesn't solve your issues it may be the screen connector or even worse a faulty screen. just try to narrow down the part.

 

do you get beeps? does the fan come on?

 

alot of times the beep or light pattern can tell you whats wrong

ZEUS-COMING SOON

            Omen 16 2021

            Zenbook 14 oled

            Vivobook 15x oled

 

Link to comment
Share on other sites

ok thanks am to update u abt that otherwise when i try to reach out to these eurocom people this is their reply """ 

We stress tested both your laptop and GPU so both were fully operational. You just need to use proper GPU (GTX 1080 or RTX 2080) in your Sky X9C. RTX 3080 is not supported. 
 
Usage of non supported hardware not listed on our website voids warranty.
 
RTX 3080 won't boot in Sky X9C - it only works in Sky Z7 R2.
 
So please use supported GPU for your laptop"""
SO AM STUCK COULD IT BE THAT FIRMWARE OF THE GPU CARD IS UPDATED THAT ITS NOLONGER PLUG AND PLAY LIKE BEFORE BASED ON THEY REPLY HOW TRUE COULD THIS BE PLEASE AM STUCK SINCE I CANT TEST ALL ITEMS SEPARATELY IMG_20230405_171839.thumb.jpg.b477a83a9872e23ed51b6abc7aa4e4bc.jpg
Link to comment
Share on other sites

Terrible thermal pads placement...the contact with the die is very poor. Use softer thermal pads.

Clevo P775TM1-G | 9900K@4.9GHz/delidded/lapped | 32Gb@3200Mhz CL14 | RTX2080@200W@2040Mhz | FHD @144Hz G-Sync | WD 2x1TB SN750 RAID0 + 2TB Samsung 870 EVO | Unlocked BIOS | 2X80mm 5V Noctua Fans@24V

Link to comment
Share on other sites

@ryan update is i get some little sound when i connect this cable near the cpu but when i power on while removed no sound 

and about cmos voltage still ok no issue even tried remove it hold down power button for same minutes on power on it feels like bios reset is their 

cpu fan active light pattern seems normal keyboard caps lock works wen placed changed ram to all slots one at a time 

conclusion i still hv no screen lightup or any words or display and still stuck IMG_20230503_174210.thumb.jpg.8b02a156e35043bd1023501203a0685f.jpg

Link to comment
Share on other sites

Brother I hate to say it but it sounds like a faulty motherboard if the ram swaps and cmos reset didn't do the trick. not alot it could be

 

the last and only thing it could be is power.

ZEUS-COMING SOON

            Omen 16 2021

            Zenbook 14 oled

            Vivobook 15x oled

 

Link to comment
Share on other sites

I would take it to a repair shop so they can do multimeter readings on it to see if its the mother board

ZEUS-COMING SOON

            Omen 16 2021

            Zenbook 14 oled

            Vivobook 15x oled

 

Link to comment
Share on other sites

  • 1 month later...
On 5/3/2023 at 9:57 AM, oops said:

@ryan update is i get some little sound when i connect this cable near the cpu but when i power on while removed no sound 

and about cmos voltage still ok no issue even tried remove it hold down power button for same minutes on power on it feels like bios reset is their 

cpu fan active light pattern seems normal keyboard caps lock works wen placed changed ram to all slots one at a time 

conclusion i still hv no screen lightup or any words or display and still stuck IMG_20230503_174210.thumb.jpg.8b02a156e35043bd1023501203a0685f.jpg

The 3080 isn't supported UNLESS you have a Prema BIOS or the Dsanke BIOS. The computer won't boot with the stock BIOS and a 30 series card. You should get a BIOS programmer and flash the BIOS on there manually. There are many tutorials online of how to go about doing that.

As for that fan cable, it is meant for the non-existent 4th fan for the CPU on the TM models. I believe it uses a lower voltage than the regular CPU fan header, so don't plug anything into it.

Clevo P870TM-G: Core i7 8700k @ 4.8ghz | Clevo GTX 1080 | 32gb HyperX DDR4 @ 3200mhz | 17" 1440p 120hz B173QTN01.0 Screen | 256gb Samsung 850 EVO | 500gb WD Blue SSD | 1tb Samsung 870 QVO | 2tb Seagate 5400rpm HDD | Prema BIOS
 

Alienware 17 R1: Core i7 4710mq @ 3.619ghz 741 CBR15 (834 CBR15 @ 4.213ghz) | Dell GTX 860m | 16gb HyperX DDR3L @ 2133mhz | 17" 3D 120hz LTN173HT02-T01 Screen | 256gb mSATA SSD

Asus Zephyrus G14: Ryzen 7 4800hs @ 4.2ghz | GTX 1650 | 16gb DDR4 @ 3200mhz | 14" 120hz LM140LF1F01 Screen | 512gb NVME SSD

 

 

Link to comment
Share on other sites

12 hours ago, Tenoroon said:

The 3080 isn't supported UNLESS you have a Prema BIOS or the Dsanke BIOS. The computer won't boot with the stock BIOS and a 30 series card. You should get a BIOS programmer and flash the BIOS on there manually. There are many tutorials online of how to go about doing that.

As for that fan cable, it is meant for the non-existent 4th fan for the CPU on the TM models. I believe it uses a lower voltage than the regular CPU fan header, so don't plug anything into it.

Is a bios mod realy requiered? @Developer79 say it is not necesary.

To be honest he could just flash Dsanke bios with a programer and try. No harm can be done at this point.

 

Clevo P870DM-G | i9-9700K 4.5 Ghz on all cores (-50 mv undervolted) | 32GB Hyper X Black 2666MHz | Clevo RTX 2080 3.1b undervolted for better temp 1905Mhz @881 mv | AUO B173HAN03.1 144hz Gsync | Samsung 980 NVME | Dsanke TM BIOS - Chujoi13 adapted based on needs | Network Card: Intel AX210-AX | Windows 10 Pro x64

Link to comment
Share on other sites

8 hours ago, runix18 said:

s a bios mod realy requiered? @Developer79 say it is not necesary.

To be honest he could just flash Dsanke bios with a programer and try. No harm can be done at this point.

 

21 hours ago, Tenoroon said:

The 3080 isn't supported UNLESS you have a Prema BIOS or the Dsanke BIOS. The computer won't boot with the stock BIOS and a 30 series card. You should get a BIOS programmer and flash the BIOS on there manually. There are many tutorials online of how to go about doing that.

As for that fan cable, it is meant for the non-existent 4th fan for the CPU on the TM models. I believe it uses a lower voltage than the regular CPU fan header, so don't plug anything into it.

I can repeat it again with pleasure, no matter if Prema or Dsanke Bios, for the operation of RTx30xx series it is not necessary to have a modified Bios on the laptop. On both P870xx and P775xx laptops only "Unknow" card appears in the bios menu and the rest goes normally. When installing the driver, you only have to do a small step more. It depends on what drivers you install. I have been using only desktop drivers for years. I recently installed the latest 535.98, and even with Dsanke Bios a clean installation is only possible with driver deactivation. That is my experience. So it doesn't matter how you do it, from my point of view, the driver installation works either way in the same time frame!...I don't know why people always think it can't be done 🙂

 

On 5/1/2023 at 7:01 AM, oops said:
We stress tested both your laptop and GPU so both were fully operational. You just need to use proper GPU (GTX 1080 or RTX 2080) in your Sky X9C. RTX 3080 is not supported. 
 
Usage of non supported hardware not listed on our website voids warranty.
 
RTX 3080 won't boot in Sky X9C - it only works in Sky Z7 R2.
 
So please use supported GPU for your laptop"""
SO AM STUCK COULD IT BE THAT FIRMWARE OF THE GPU CARD IS UPDATED THAT ITS NOLONGER PLUG AND PLAY LIKE BEFORE BASED ON THEY REPLY HOW TRUE COULD THIS BE PLEASE AM STUCK SINCE I CANT TEST ALL ITEMS SEPARATELY 

Of course, that's what Eurocom says! After all, they are not developers or engineers or hobbyists! In the series P870DM23 / KM / TM is bios sided original from Clevo everything in order only you need either a new heatsink from Aliexpress or appropriate adapters with which you can screw the original heatsinks normally with the RTX30xx series and some processing of the heatsink! Then it can already start with the operation!:-)

Link to comment
Share on other sites

do you have backlight ? if u put usb drive with a led light in it, does it blink ? synthom without ram are the same? without gpu?

 

without ram or gpu it should act different.... like with no ram beep; if it is still the same is cpu compatible ? installed properly ?

 

it should support till serie 7 of intel if bios is original.

Link to comment
Share on other sites

2 hours ago, Scruffy said:

do you have backlight ? if u put usb drive with a led light in it, does it blink ? synthom without ram are the same? without gpu?

 

without ram or gpu it should act different.... like with no ram beep; if it is still the same is cpu compatible ? installed properly ?

 

it should support till serie 7 of intel if bios is original.

I think that beeing a TM it will support only 8 and 9th series on stock bios.

Clevo P870DM-G | i9-9700K 4.5 Ghz on all cores (-50 mv undervolted) | 32GB Hyper X Black 2666MHz | Clevo RTX 2080 3.1b undervolted for better temp 1905Mhz @881 mv | AUO B173HAN03.1 144hz Gsync | Samsung 980 NVME | Dsanke TM BIOS - Chujoi13 adapted based on needs | Network Card: Intel AX210-AX | Windows 10 Pro x64

Link to comment
Share on other sites

30 minutes ago, runix18 said:

I think that beeing a TM it will support only 8 and 9th series on stock bios.

yes, that's exactly how it is! And with hardware mods the 10th gen notebook. See VictorV Mods. But that only works because the electrical phases of the different generations are the same. Otherwise you would need a new motherboard with the appropriate multiphase design...

Link to comment
Share on other sites

HI EVERYBODY HERE THANKS IN ADVANCE BEEN FOLLOWING AND MY UPDATE IS I SENT FOR PROGRAMMER AND GTX1080 CARD I WANT TO FLASH IT MY SELF THOUGH THE REPAIR SHOP HAD SAID IT TRIED EVERYTHING INCLUDING FLASHING THE BIOS BUT I DDNT TRUST THEM SO LET ME DO HANDS ON I GET THE REAL RESULTS THEN GIVE U FEEDBACK BY NEXT WEEK.

Link to comment
Share on other sites

3 hours ago, Scruffy said:

i mean he has no display, but without ram does the pc make some beeping ? (so it mean pc see the ram when inserted). things like that.

Ok, I understand!:-) These are possibilities, yes!

 

4 hours ago, oops said:

HI EVERYBODY HERE THANKS IN ADVANCE BEEN FOLLOWING AND MY UPDATE IS I SENT FOR PROGRAMMER AND GTX1080 CARD I WANT TO FLASH IT MY SELF THOUGH THE REPAIR SHOP HAD SAID IT TRIED EVERYTHING INCLUDING FLASHING THE BIOS BUT I DDNT TRUST THEM SO LET ME DO HANDS ON I GET THE REAL RESULTS THEN GIVE U FEEDBACK BY NEXT WEEK.

Ok, if your store is familiar with modifying such laptops, then everything fits!

Link to comment
Share on other sites

HI THERE UPDATE NOW I PUT THE GTX 1080 WITH NEW GPU CABLE BUT SAME RAM CPU BUT STILL SAME RESULTS LIKE BEFORE WITH RTX 3080 SO HEART BREAKING INDEED NOW AM HEADING IN DIRECTION OF TRYING THIS SCREEN WITH DIFFERENT LAPTOP IF PIN MATCH THATS HOW I STAND AT THIS POINT MAYBE EVEN REFLASHING SINCE THE PROGRAMMER CAME 
AND CAN I BE WITH CAPS ON KEYBOARD RESPONDING AND CPU IS DEAD BECAUSE AT THIS POINT I CANT TELL IF THE CPU IS WORKING ON DEAD ????? BUT CAPS WORKS FINE 

Link to comment
Share on other sites

2 hours ago, oops said:

hi, seller sent this picture on test, is vbios the issue please just inquiringS0da5378c85184d8586bce802f0339df8E.thumb.jpg.de62ed171b1afed97c968ec6ac311e3f.jpg

That is a TM  gpu suplied vbios. That is not the problem.

Clevo P870DM-G | i9-9700K 4.5 Ghz on all cores (-50 mv undervolted) | 32GB Hyper X Black 2666MHz | Clevo RTX 2080 3.1b undervolted for better temp 1905Mhz @881 mv | AUO B173HAN03.1 144hz Gsync | Samsung 980 NVME | Dsanke TM BIOS - Chujoi13 adapted based on needs | Network Card: Intel AX210-AX | Windows 10 Pro x64

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Terms of Use