Jump to content
NotebookTalk

Should I buy it?


aldarxt

Recommended Posts

I'm starting a new topic because.

I saw an Alienware 17 R1 P18e 17.3" Laptop i7-4910MQ 2.90GHz 16GB RAM for $275.49 it looks to have a bad gpu or 2 different gpus and they dont know how to mod .infs. I was wondering if a quadro p4000 will work in it cause of the screen being LCD,17.3FHD,WLED,LVDS,AG,Z,LGD - INFO,SWSI,LCD,17.3,NON-TCH  and my m18xr2 has LCD,18.4FHD,WLED,TLF,SMSNG. The LVDS is not supported by p4000 so I just want to pick some brains to help straighten me out. The m18xr2 has the p4000 working very well and was so happy with it I bought another but have no where to put it, so I want to buy a laptop to put it in. LAMS (laughing at my self) And dont know what P18E means

Clevo P870DM3-G i9-9900k-32.0GB 2667mhz-RTX3080+GTX1080

Alienware M18x R2 i7-3920xm-32GB DDR3-RTX 3000 

Alienware M17x R4 i7-3940XM-16GB DDR3-RTX 3000

Alienware M17x R4 i7-3940XM 20GB DDR3-P4000 120hz 3D

Precision m6700 i7-3840QM-16GB DDR3-GTX 970M 
Precision m4700 i7-3740QM-16GB DDR3-T2000M

GOBOXX SLM  G2721-i7-10875H RTX 3000-32GB ddr4

 

Link to comment
Share on other sites

The P18e is just a model number. This laptop has different names depending where you are in the world, Ranger, 17, 17R1, M17X R5 all have P18e stamped on bottom cover.

The motherboard on these has LVDS and EDP connectors

If the current screen is LVDS then its 60hz

You could buy 120hz screen and EDP cable, that might (or might not work) with Quadro card.

@Mogrules named the correct EDP cable here

https://www.nbrchive.net/xfa/alienware-17-and-m17x.1079/120Hz 3D Screen upgrade for Alienware 17 R1/

  • Thumb Up 1

Thunderchild // Lenovo Legion Y740 17" i7-9750H rtx2080maxQ win10 

RainBird // Alienware 17 (Ranger) i7-4910mq gtx860m win10LTSC

 

 

Link to comment
Share on other sites

  • 2 weeks later...

I'm running a p4000 in M17x R4 with the 60hz LVDS display, using NVIDIA optimus, and modded drivers. I can't guarantee it'll work in the R5, but it seems pretty likely as it works fine in mine. if you need, I could probably make some modded drivers for you or instruct you on how to mod them, I've done it a couple of times myself.

OWNED:

14 R1 - 4710MQ @ 3.6 Ghz, hd 4600, 12gb DDR3L 1600 Mhz

JANKTOP IV Mini-ITX Laptop - R5 2600X, 16gb DDR4 3000 Mhz, RX 5700 XT - (ONGOING)

Under my wing:

15 R3 - GTX 1060 6gb, i7 7700HQ, 16gb DDR4

17 R4 - RX 470 8gb i7 6700HQ, 16gb DDR4

M17x R4 - 3630QM, Quadro P4000, 16gb DDR3L 1600 Mhz 

M17x R2 - i7 920XM @ 3.4 Ghz, GTX 770m 2gb, 16gb DDR3

Link to comment
Share on other sites

43 minutes ago, StripeySnake said:

I'm running a p4000 in M17x R4 with the 60hz LVDS display, using NVIDIA optimus, and modded drivers. I can't guarantee it'll work in the R5, but it seems pretty likely as it works fine in mine. if you need, I could probably make some modded drivers for you or instruct you on how to mod them, I've done it a couple of times myself.

Thanks for the offer, I know how to mod the .inf and I didn't buy that machine, Happily I bought a m17x r4 but with lcd screenand the p4000 installed easily with modded drivers and a new cpu i7-3940xm and a 2tb 860 QVO and 4x4gb 1866mhz ram and running Flawlessly Magnificent. I am now the Proud owner of 2 Alienware's an m18xr2 and an m17xr4. The 18 I had since 10/12/2012 and it is going strong, and there is still Future Hope for them. Now I see 120hz screens on the horizon!!!

  • Thumb Up 1

Clevo P870DM3-G i9-9900k-32.0GB 2667mhz-RTX3080+GTX1080

Alienware M18x R2 i7-3920xm-32GB DDR3-RTX 3000 

Alienware M17x R4 i7-3940XM-16GB DDR3-RTX 3000

Alienware M17x R4 i7-3940XM 20GB DDR3-P4000 120hz 3D

Precision m6700 i7-3840QM-16GB DDR3-GTX 970M 
Precision m4700 i7-3740QM-16GB DDR3-T2000M

GOBOXX SLM  G2721-i7-10875H RTX 3000-32GB ddr4

 

Link to comment
Share on other sites

AW 17 R1 can also run P4000 in SG (Optimus) mode using unlocked BIOS. Just wanted to clarify this. 

 

Congrats on the M17xR4, one of my favorite designs. 

  • Thumb Up 1

Alienware m18             : Intel Core i9 13900HX                  | nVidia GeForce RTX 4090    | K1675 | 2x1TB SSDs 

Alienware Area-51M : Intel Core i9-9900K @ 5.3Ghz    | nVidia GeForce RTX 2080    | AX210 | Samsung 970 Evo+ 
Alienware M18x R2 :    Intel Core i7 3920XM @ 4.7Ghz | nVidia Quadro RTX 3000     | AX210 | Samsung 980 PRO   
Clevo X170SM-G:         Intel Core i7 10700K @ Stock     | nVidia GeForce RTX 2070S | AX210 | 256GB+2x512GB 

More Laps: M14x (555m) | M14xR2 (650m) | M15x (980m) | M17xR3 (880m) | M18xR1 (880m SLI) | 18 R1 (RTX 3000)

DT: Aurora R4 (i9 10980XE/RTX 4070) | Area-51 R2 (22-Core Xeon/2x Titan V) | SR-2 [2x6-Core/3x980Ti] | Mac Studio


CS Studios YouTube: https://www.youtube.com/c/CSStudiosYT 

Link to comment
Share on other sites

Love the R4 too. Is it possible to run p4000 in r5 with locked BIOS? I only ask because my R4 is running the locked A15 BIOS, and it works fine.

OWNED:

14 R1 - 4710MQ @ 3.6 Ghz, hd 4600, 12gb DDR3L 1600 Mhz

JANKTOP IV Mini-ITX Laptop - R5 2600X, 16gb DDR4 3000 Mhz, RX 5700 XT - (ONGOING)

Under my wing:

15 R3 - GTX 1060 6gb, i7 7700HQ, 16gb DDR4

17 R4 - RX 470 8gb i7 6700HQ, 16gb DDR4

M17x R4 - 3630QM, Quadro P4000, 16gb DDR3L 1600 Mhz 

M17x R2 - i7 920XM @ 3.4 Ghz, GTX 770m 2gb, 16gb DDR3

Link to comment
Share on other sites

On 2/24/2022 at 7:03 PM, StripeySnake said:

Love the R4 too. Is it possible to run p4000 in r5 with locked BIOS? I only ask because my R4 is running the locked A15 BIOS, and it works fine.

As long as it is running in Optimus mode (60hz panel) or dGPU only (120hz) it will run. I think the 17 series by default on 60hz panel run in Optimus mode? 

Alienware m18             : Intel Core i9 13900HX                  | nVidia GeForce RTX 4090    | K1675 | 2x1TB SSDs 

Alienware Area-51M : Intel Core i9-9900K @ 5.3Ghz    | nVidia GeForce RTX 2080    | AX210 | Samsung 970 Evo+ 
Alienware M18x R2 :    Intel Core i7 3920XM @ 4.7Ghz | nVidia Quadro RTX 3000     | AX210 | Samsung 980 PRO   
Clevo X170SM-G:         Intel Core i7 10700K @ Stock     | nVidia GeForce RTX 2070S | AX210 | 256GB+2x512GB 

More Laps: M14x (555m) | M14xR2 (650m) | M15x (980m) | M17xR3 (880m) | M18xR1 (880m SLI) | 18 R1 (RTX 3000)

DT: Aurora R4 (i9 10980XE/RTX 4070) | Area-51 R2 (22-Core Xeon/2x Titan V) | SR-2 [2x6-Core/3x980Ti] | Mac Studio


CS Studios YouTube: https://www.youtube.com/c/CSStudiosYT 

Link to comment
Share on other sites

  • 2 months later...

Should I buy it? An m18xr3 CPU heatsink to put in m18xr2? cant find anything on the difference of the 2 heatsinks. The m18r3 CPU heatsink has a copper vapor chamber that I think will keep my i7-3940 cooler than the triple pipe I have in there now. It throttles at 85C and when I increased the throttle to 90c it cold clocked it. Just knocked it out dead. So no sence in overclocking, but if I can keep it cooler with the vapor chamber I should be able to clock it higher. It doesn't stay hot, just peaks for a couple of seconds and drops back down to a compfortable temp. I can't see any difference but the 1 with the vapor chamber is $60 so before I get it just want to make sure I don't need a hammer and a chisel to wedge it in. Any insight would be much appreciated.

s-l1600_cr.jpg

s-l1600a.jpg

Clevo P870DM3-G i9-9900k-32.0GB 2667mhz-RTX3080+GTX1080

Alienware M18x R2 i7-3920xm-32GB DDR3-RTX 3000 

Alienware M17x R4 i7-3940XM-16GB DDR3-RTX 3000

Alienware M17x R4 i7-3940XM 20GB DDR3-P4000 120hz 3D

Precision m6700 i7-3840QM-16GB DDR3-GTX 970M 
Precision m4700 i7-3740QM-16GB DDR3-T2000M

GOBOXX SLM  G2721-i7-10875H RTX 3000-32GB ddr4

 

Link to comment
Share on other sites

@aldarxt The screw mounts are in different locations between the M18x R2 and AW18. Both the images you've posted are for the AW18 (M18x R3)

 

See how the screws are pretty much in a perfect square below. The AW18 screws are off-set, as per your images.

 

image.png.b7d5dc1c5375eea30931aa93527e0a30.png

  • Thumb Up 1
  • Thanks 1

Alienware Aurora R15 - i9-13900KF - RTX 4090 - 32GB DDR5 

Alienware M18x R2 - i7-3920XM - GTX 970M - 16GB 1866Mhz DDR3L - Samsung 970 Evo with MXM to NVMe Adapter - Custom Delft Blue  

Alienware X51 - i7-3770 - NO GPU - 16GB 1600Mhz DDR3  Alienware M17x R3 - i7-2760QM - GTX 580M - 16GB 1600Mhz DDR3

Alienware Area 51 ALX - i7-975 Extreme - GTX 980 - 16GB 1600Mhz DDR3   Alienware Aurora R2 - i7-3770K - GTX 670FTW - 16GB 1600Mhz DDR3 

Alienware Aurora R4 ALX - i7-3930K - GTX 1060 - 16GB 1600Mhz DDR3        Alienware Aurora R4 ALX - i7-3930K - GTX 670FTW - 16GB 1600Mhz DDR3

 

Link to comment
Share on other sites

1 hour ago, Maxware79 said:

@aldarxt The screw mounts are in different locations between the M18x R2 and AW18. Both the images you've posted are for the AW18 (M18x R3)

 

See how the screws are pretty much in a perfect square below. The AW18 screws are off-set, as per your images.

 

image.png.b7d5dc1c5375eea30931aa93527e0a30.png

Thanks Maxware79, Thats a very minute difference that could cause alot of grief!!!

Clevo P870DM3-G i9-9900k-32.0GB 2667mhz-RTX3080+GTX1080

Alienware M18x R2 i7-3920xm-32GB DDR3-RTX 3000 

Alienware M17x R4 i7-3940XM-16GB DDR3-RTX 3000

Alienware M17x R4 i7-3940XM 20GB DDR3-P4000 120hz 3D

Precision m6700 i7-3840QM-16GB DDR3-GTX 970M 
Precision m4700 i7-3740QM-16GB DDR3-T2000M

GOBOXX SLM  G2721-i7-10875H RTX 3000-32GB ddr4

 

Link to comment
Share on other sites

  • 1 year later...

Hi all, after several searches I came across this forum, I hope I can fix a problem with my m17x r4. I have a gtx 680m 2gb gpu and a 60hz panel and i have unlocked bios a15. Everything worked fine and I had the 120Hz panel installed at the time. When I tried to install the quadro p4000 gpu the problems started!! On the first boot I had 8 beeps, then on the second boot the machine booted up but black screen, even pressing f2 to enter the bios black screen, but I know it's in the bios, in fact as soon as I press the power key it shuts down. Desperate, he installs a 60Hz panel and displays the picture. In the bios I see the dedicated graphics card. i exit the bios and load the operating system, and in the device manager i see 2 generic microsoft video cards and the intel 4000. i can't create the .inf file for the p4000 framework, if you could have it for me i would be grateful. So I removed the p4000 and installed the grx 680m 2gb with the drivers from the nvidia site, without modifying it and it installed fine. Now another problem has arisen when I press fn+f7 the pc restarts and switches to the 680m gpu and no image on the display!!!!! Connecting it to the tv via hdmi I have a picture, I can't see the bios by pressing f2, but only when the operating system loads. I tried to reinstall the original bios of the a15 but nothing changes. What could be this problem, the motherboard? Or damaged Bios? Or other? I hope someone can help me reset it. I have been doing tests on tests with negative results for 3 days. Thanks all Now another problem came up when I press fn+f7 the pc restarts and switches to 680m gpu and no image on display!!!!! Connecting it to the tv via hdmi I have a picture, I can't see the bios by pressing f2, but only when the operating system loads. I tried to reinstall the original bios of the a15 but nothing changes. What could be this problem, the motherboard? Or damaged Bios? Or other? I hope someone can help me reset it. I have been doing tests on tests with negative results for 3 days. Thanks all Now another problem came up when I press fn+f7 the pc restarts and switches to 680m gpu and no image on display!!!!! Connecting it to the tv via hdmi I have a picture, I can't see the bios by pressing f2, but only when the operating system loads. I tried to reinstall the original bios of the a15 but nothing changes. What could be this problem, the motherboard? Or damaged Bios? Or other? I hope someone can help me reset it. I have been doing tests on tests with negative results for 3 days. Thanks all What could be this problem, the motherboard? Or damaged Bios? Or other? I hope someone can help me reset it. I have been doing tests on tests with negative results for 3 days. Thanks all What could be this problem, the motherboard? Or damaged Bios? Or other? I hope someone can help me reset it. I have been doing tests on tests with negative results for 3 days. Thank you all

Link to comment
Share on other sites

@Astrolopiteco I saw your post on the TechInferno site but those guys are d1ckheads so I refuse to engage with that forum any longer. 

 

If you can see the P4000 in Device Manager with the 60hz panel then that's a good start. It means the system detects the card so you should be able to get it working. Why are you having troubles creating the .inf file? It's not too hard if you find a good tutorial and once you learn how to do it it's incredibly easy and you can keep the driver updated as often as you want without having to ask others. If you need some step by step help then ask away and I'll do my best. 

I'm not entirely sure why it won't work with the 120hz panel installed though. There shouldn't be any reason to require the BIOS being set to UEFI as I had a 1070 working in my M18x R2 while in Legacy mode. Although, the black screen you're getting is very much like what would happen with a 900M series card in a system that isn't set to UEFI mode. Just check to see what you're set to and make some changes to see what happens. 

If you're on Legacy and switch to UEFI then you will have to reinstall Windows. If you're already on UEFI then check to see if you have Load Legacy Option ROM enabled. If it is, disable it (and secure boot). 

Try this and see if that makes any difference. 

The Fn-F7 switch is mainly for the M18x so I'd suggest not to use it for your M17x. If you have the 120Hz then you will be on PEG by default and this cannot be changed. If you have the 60hz installed then just leave it on SG mode. 

If you have the 60hz currently installed, make the UEFI changes as I mentioned above and shut the system down. Install the P4000 and the 120hz display and see if you get a display. 

 

 

Alienware Aurora R15 - i9-13900KF - RTX 4090 - 32GB DDR5 

Alienware M18x R2 - i7-3920XM - GTX 970M - 16GB 1866Mhz DDR3L - Samsung 970 Evo with MXM to NVMe Adapter - Custom Delft Blue  

Alienware X51 - i7-3770 - NO GPU - 16GB 1600Mhz DDR3  Alienware M17x R3 - i7-2760QM - GTX 580M - 16GB 1600Mhz DDR3

Alienware Area 51 ALX - i7-975 Extreme - GTX 980 - 16GB 1600Mhz DDR3   Alienware Aurora R2 - i7-3770K - GTX 670FTW - 16GB 1600Mhz DDR3 

Alienware Aurora R4 ALX - i7-3930K - GTX 1060 - 16GB 1600Mhz DDR3        Alienware Aurora R4 ALX - i7-3930K - GTX 670FTW - 16GB 1600Mhz DDR3

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Terms of Use