Jump to content
NotebookTalk

m17x r4 not detecting gtx 980m in unlocked bios


 Share

Recommended Posts

I'm attempting to install a gtx 980m into my m17x r4. I have an unlocked a15 bios booting into pure UEFI, but the "Discrete Graphics" still says "Not Detected". I haven't really messed with any bios settings other than changing to pure UEFI. Is there some explanation for why the gpu wouldn't be detected at all, other than a dead card?

Link to comment
Share on other sites

um...how do get display output? are u running on integrated graphics? in general, that entry in the bios doesnt really mean anything, as long as the card itself works 🙂 

Mine: Hyperion "Titan God of Heat, Heavenly Light, Power" (2022)
AMD Ryzen 9 7950X / Asus ROG Crosshair X670E Extreme / MSI Geforce RTX 4090 Suprim X / G.Skill Trident Z5 RGB DDR5-6600 2x16 GB / Seagate Firecuda 530 4 TB / 2x Samsung 860 Evo 4 TB / Arctic Liquid Freezer II 420 / Seasonic TX-1600 W Titanium / Phanteks Enthoo Pro 2 TG / Samsung Odyssey Neo G8 32" UHD 240 Hz / Ducky One 3 Daybreak Fullsize Cherry MX Brown / Corsair M65 Ultra RGB

 

My Lady's: Clevo NH55JNNQ "Alfred" (2022)
Sharp LQ156M1JW03 FHD matte 15.6" IGZO 8 bit @248 Hz / Intel 12600 @ 4.4 - 4.8 Ghz / Nvidia 3070 Ti 8 GB GDDR6 / G.Skill 16 GB DDR4-3800 / Samsung 970 Pro 1 TB / Intel AX201 ax+BT / Win 11 Pro Phoenix Lite OS / 230 W PSU powered by Prema Mod!

Link to comment
Share on other sites

Unfortunately, an undetected card in the BIOS usually means that it's dead. You could try removing it and making sure all the pins on the card and the MXM slot are clean and try reseating it. 

The 900M series need UEFI mode but that shouldn't stop it being detected at all.

Alienware M18x R2 - i7-3920XM - GTX 970M - 16GB 1866Mhz DDR3L - Samsung 970 Evo with MXM to NVMe Adapter - Custom Delft Blue

Alienware M18x R2 - i7-3840QM - GTX 680M - 16GB 1600Mhz - Custom Yellow     Alienware M17x R3 - i7-2760QM - GTX 580M - 16GB 1600Mhz DDR3

Alienware M17x R2 - i7-720MQ - GTX 460M - 8GB 1600Mhz DDR3 - 1920x1200 RGBLED   Alienware X51 - i7-3770 - NO GPU - 16GB 1600Mhz DDR3

Alienware Area 51 ALX - i7-975 Extreme - GTX 980 - 16GB 1600Mhz DDR3   Alienware Aurora R2 - i7-3770K - GTX 670FTW - 16GB 1600Mhz DDR3 

Alienware Aurora R4 ALX - i7-3930K - GTX 1060 - 16GB 1600Mhz DDR3        Alienware Aurora R4 ALX - i7-3930K - GTX 670FTW - 16GB 1600Mhz DDR3

 

Link to comment
Share on other sites

  • 4 weeks later...
On 7/18/2022 at 9:44 PM, ChuckWhip said:

I'm attempting to install a gtx 980m into my m17x r4. I have an unlocked a15 bios booting into pure UEFI, but the "Discrete Graphics" still says "Not Detected". I haven't really messed with any bios settings other than changing to pure UEFI. Is there some explanation for why the gpu wouldn't be detected at all, other than a dead card?

Good afternoon. Do you have a unlocked bios 15? Could you give a link to it? Thanks.

Alienware 17 : Intel Core i7 4900QM @ 3.8Ghz   | nVidia GeForce GTX 980M 8GB (OC)   | 32gb DDR3 1600MHZ | x2 Samsung 860 Evo 500GB (Raid).

Alienware M17x R2 : Intel Core i7 940XM @ 3.50Ghz   | nVidia QUADRO M4000M 4GB (OC)   | 16gb DDR3 1333MHZ | SSD 250GB + HDD 1000GB.

Link to comment
Share on other sites

18 hours ago, Komputers-Best said:

Good afternoon. Do you have a unlocked bios 15? Could you give a link to it? Thanks.

 

It's here in this forum. 

 

Alienware M18x R2 - i7-3920XM - GTX 970M - 16GB 1866Mhz DDR3L - Samsung 970 Evo with MXM to NVMe Adapter - Custom Delft Blue

Alienware M18x R2 - i7-3840QM - GTX 680M - 16GB 1600Mhz - Custom Yellow     Alienware M17x R3 - i7-2760QM - GTX 580M - 16GB 1600Mhz DDR3

Alienware M17x R2 - i7-720MQ - GTX 460M - 8GB 1600Mhz DDR3 - 1920x1200 RGBLED   Alienware X51 - i7-3770 - NO GPU - 16GB 1600Mhz DDR3

Alienware Area 51 ALX - i7-975 Extreme - GTX 980 - 16GB 1600Mhz DDR3   Alienware Aurora R2 - i7-3770K - GTX 670FTW - 16GB 1600Mhz DDR3 

Alienware Aurora R4 ALX - i7-3930K - GTX 1060 - 16GB 1600Mhz DDR3        Alienware Aurora R4 ALX - i7-3930K - GTX 670FTW - 16GB 1600Mhz DDR3

 

Link to comment
Share on other sites


Thanks!

Alienware 17 : Intel Core i7 4900QM @ 3.8Ghz   | nVidia GeForce GTX 980M 8GB (OC)   | 32gb DDR3 1600MHZ | x2 Samsung 860 Evo 500GB (Raid).

Alienware M17x R2 : Intel Core i7 940XM @ 3.50Ghz   | nVidia QUADRO M4000M 4GB (OC)   | 16gb DDR3 1333MHZ | SSD 250GB + HDD 1000GB.

Link to comment
Share on other sites

Result 3840QM @ 3.7Ghz, 980M(OC).

222.jpg

Alienware 17 : Intel Core i7 4900QM @ 3.8Ghz   | nVidia GeForce GTX 980M 8GB (OC)   | 32gb DDR3 1600MHZ | x2 Samsung 860 Evo 500GB (Raid).

Alienware M17x R2 : Intel Core i7 940XM @ 3.50Ghz   | nVidia QUADRO M4000M 4GB (OC)   | 16gb DDR3 1333MHZ | SSD 250GB + HDD 1000GB.

Link to comment
Share on other sites

  • 2 months later...
On 7/18/2022 at 2:44 PM, ChuckWhip said:

I'm attempting to install a gtx 980m into my m17x r4. I have an unlocked a15 bios booting into pure UEFI, but the "Discrete Graphics" still says "Not Detected". I haven't really messed with any bios settings other than changing to pure UEFI. Is there some explanation for why the gpu wouldn't be detected at all, other than a dead card?

OK 2day I took the p4000 out of m17x r4 Black and tried it in m17x r4 Red = 8 beeps. Then tried GTX 970m in the Red = 8 beeps. I put the GTX 680m back in Red = all good. The Red has 120hz 3D screen and can only run PEG. No SG, No IGFX. It is EUFI. The Black has 1600x900 LVDS screen, EUFI and runs the P4000 Flawlessly in SG mode. So I tried the GTX 980m in the Black and will only work in SG mode, if I try PEG gets 8 beeps. I would like to upgrade the Red GPU. I tried switching the video cable under the keyboard but got 8 beeps. I have A11 unlocked bios in both.

If you do a cmos reset it should see the card, unless the card is bad as was stated before. I purchased my GTX 980m on aliexpress cheap $200 and it is lacking, crashing, overclocking 60mhz base clock crashes Firestrike so am not happy with this GTX 980m.

Alienware M18x R2 i7-3920xm-16GB DDR3-Quadro P4000  Alienware M17x R4 i7-3940XM 16GB DDR3-1866 Quadro P4000

Precision m6700 i7-3840QM - 16.0GB DDR3 - GTX 970M     Alienware M17x R4 i7-3940XM 32GB DDR3-1600 GTX 680M 120hz 3D
Precision m4700 i7-3610QM-8.00GB DDR3 @ 1600MHz-K2000M

GOBOXX SLM  G2721-i7-10875H RTX 3000-32GB ddr4(Gave to my Wife)

 

Link to comment
Share on other sites

980M's out of China are notoriously bad. Just make sure that you also have Load Legacy Option ROM and Secure Boot disabled with the UEFI setting enabled. Also try not plugging in the 3D emitter cable coming from the LCD that plugs in near to the display cable connector. I had a 780M that was acting weird and once I unplugged this connector from the board it started working properly. 

 

From what I have been told, the Chinese 980M's are just 980M dies on homemade PCB's so the quality is not like an OEM card, even if they look the same. 

 

Alienware M18x R2 - i7-3920XM - GTX 970M - 16GB 1866Mhz DDR3L - Samsung 970 Evo with MXM to NVMe Adapter - Custom Delft Blue

Alienware M18x R2 - i7-3840QM - GTX 680M - 16GB 1600Mhz - Custom Yellow     Alienware M17x R3 - i7-2760QM - GTX 580M - 16GB 1600Mhz DDR3

Alienware M17x R2 - i7-720MQ - GTX 460M - 8GB 1600Mhz DDR3 - 1920x1200 RGBLED   Alienware X51 - i7-3770 - NO GPU - 16GB 1600Mhz DDR3

Alienware Area 51 ALX - i7-975 Extreme - GTX 980 - 16GB 1600Mhz DDR3   Alienware Aurora R2 - i7-3770K - GTX 670FTW - 16GB 1600Mhz DDR3 

Alienware Aurora R4 ALX - i7-3930K - GTX 1060 - 16GB 1600Mhz DDR3        Alienware Aurora R4 ALX - i7-3930K - GTX 670FTW - 16GB 1600Mhz DDR3

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Terms of Use