Jump to content
NotebookTalk

Windows 11 Modern Standby Problems


John Ratsey

Recommended Posts

I'm getting frustrated by Modern Standby on my LG Gram 17 (2022) with Windows 11. When I tell the computer to Sleep then the fan keeps running and running. In reality, it's not sleeping at all but just turns off the display and keeps everything running. One consequence of this is the risk of overheating when the screen is closed and heat dissipation is less effective. Battery drain is also much higher than the traditional sleep. I wonder if Modern Standby was created for desktop computers and has been inflicted on notebooks without proper thought.

 

The traditional low power sleep uses low power state S3. However, when low power state S0 is enabled in the BIOS then other sleep states are automatically disabled.

1081423357_SleepstateswithS0enabled.jpg.551c0986d60afb89a50b97cdc0c97b7c.jpg

Using a registry entry to disable S0 seems to work when telling the computer to sleep - it quickly goes quiet - but reboots when told to wake up. I've also tried disabling S0 in the BIOS and Powercfg /a shows that this enables the other sleep states. However, the reboot on wake problem still happens. There is some potentially relevant discussion here but I think the problem is if wider interest to notebook users.

 

I suspect that something else in Windows needs to be changed to ensure trouble-free waking when Modern Standby is disabled.Ideally, S0 would be disabled before Windows is installed and Windows would then configure itself accordingly. Has anyone else had this problem and managed to solve it?

 

  • Bump 1
Link to comment
Share on other sites

On the Dell side, it seems to be that tricks like this to enable S3 sleep and try to use it don't really work — BIOS support for it is non-existent or half-baked, since they just expect you to be using "Modern Standby" (which everybody hates).  I don't know of anyone who has gotten S3 sleep working on a Tiger Lake / 11th gen system or later (again, on the Dell side).  The general consensus is to just forget about "Sleep" and go straight to "Hibernate" 😕

  • Thumb Up 2

Apple MacBook Pro 16-inch, 2023 (personal) • Dell Precision 7560 (work) • Full specs in spoiler block below
Info posts (Dell) — Dell Precision key postsDell driver RSS feeds • Dell Fan Management — override fan behavior
Info posts (Windows) — Turbo boost toggle • The problem with Windows 11 • About Windows 10 LTSC

Spoiler

Apple MacBook Pro 16-inch, 2023 (personal)

  • M2 Max
    • 4 efficiency cores
    • 8 performance cores
    • 38-core Apple GPU
  • 96GB LPDDR5-6400
  • 8TB SSD
  • macOS 14 "Sonoma"
  • 16.2" 3456×2234 120 Hz mini-LED VRR display
  • Wi-Fi 6E + Bluetooth 5.3
  • 99.6Wh battery
  • 1080p webcam
  • Fingerprint reader

Also — iPhone 12 Pro 512GB, Apple Watch Series 8

 

Dell Precision 7560 (work)

  • Intel Xeon W-11955M ("Tiger Lake")
    • 8×2.6 GHz base, 5.0 GHz turbo, hyperthreading ("Willow Cove")
  • 64GB DDR4-3200 ECC
  • NVIDIA RTX A2000 4GB
  • Storage:
    • 512GB system drive (Micron 2300)
    • 4TB additional storage (Sabrent Rocket Q4)
  • Windows 10 Enterprise LTSC 2021
  • 15.6" 3940×2160 IPS display
  • Intel Wi-Fi AX210 (Wi-Fi 6E + Bluetooth 5.3)
  • 95Wh battery
  • 720p IR webcam
  • Fingerprint reader

 

Previous

  • Dell Precision 7530, 7510, M4800, M6700
  • Dell Latitude E6520
  • Dell Inspiron 1720, 5150
  • Dell Latitude CPi
Link to comment
Share on other sites

  • 3 months later...
On 10/26/2022 at 2:41 PM, John Ratsey said:

I'm getting frustrated by Modern Standby on my LG Gram 17 (2022) with Windows 11. When I tell the computer to Sleep then the fan keeps running and running. In reality, it's not sleeping at all but just turns off the display and keeps everything running. One consequence of this is the risk of overheating when the screen is closed and heat dissipation is less effective. Battery drain is also much higher than the traditional sleep. I wonder if Modern Standby was created for desktop computers and has been inflicted on notebooks without proper thought.

 

The traditional low power sleep uses low power state S3. However, when low power state S0 is enabled in the BIOS then other sleep states are automatically disabled.

1081423357_SleepstateswithS0enabled.jpg.551c0986d60afb89a50b97cdc0c97b7c.jpg

Using a registry entry to disable S0 seems to work when telling the computer to sleep - it quickly goes quiet - but reboots when told to wake up. I've also tried disabling S0 in the BIOS and Powercfg /a shows that this enables the other sleep states. However, the reboot on wake problem still happens. There is some potentially relevant discussion here but I think the problem is if wider interest to notebook users.

 

I suspect that something else in Windows needs to be changed to ensure trouble-free waking when Modern Standby is disabled.Ideally, S0 would be disabled before Windows is installed and Windows would then configure itself accordingly. Has anyone else had this problem and managed to solve it?

 

I just saw this post while looking for other info on the site.  I did extensive work on 'standby' issues way back, and I seem to recall posting the info here somewhere but not sure where offhand.   Did you ever make progress with this? 

 

I have the LG Gram 17, 2021 model (17Z95P-K.AAE8U1).  I disabled S0, which enables S3, using this technique: 

 

Regedit: 

HKLM\System\CurrentControlSet\Control\Power

Enter the 32-bit DWORD value PlatformAoAcOverride and set it to 0. 

 

Confirmed using powercfg /a -  available: S3, Hibernate. Not available: S1, S2, S0, hybrid sleep, fast startup. 

 

and the system goes to sleep on idle (or when asked to do so) and correctly recovers from sleep with mouse movement, etc - and doesn't reboot like yours seems to. 

 

(this is under windows 11 home). 

 

as a side note, when I just checked today, S0 was back to active, and the registry key was gone - presumably some windows update secretly reset it.  But I set it back just now, and tested - let it idle, woke it up, and ran 'powercfg /sleepstudy' to generate a report, which confirmed it went to standby. 

 

Let me know if you want to pursue this further. 

 

Link to comment
Share on other sites

7 hours ago, Steerpike said:

as a side note, when I just checked today, S0 was back to active, and the registry key was gone - presumably some windows update secretly reset it.  But I set it back just now, and tested - let it idle, woke it up, and ran 'powercfg /sleepstudy' to generate a report, which confirmed it went to standby.

 

Major Windows feature upgrades (released yearly) will reset this value.  For things like this, I have a batch script that runs at startup to just make sure the configuration is how I like, should Microsoft decide to reset it.  (Also handy to just apply your configuration to a new PC, having all of the steps in one place without having to remember everything.)  You could do something like:

 

REG ADD "HKLM\System\CurrentControlSet\Control\Power" /v PlatformAoAcOverride /t REG_DWORD /d 0 /f /reg:64

  • Thanks 1

Apple MacBook Pro 16-inch, 2023 (personal) • Dell Precision 7560 (work) • Full specs in spoiler block below
Info posts (Dell) — Dell Precision key postsDell driver RSS feeds • Dell Fan Management — override fan behavior
Info posts (Windows) — Turbo boost toggle • The problem with Windows 11 • About Windows 10 LTSC

Spoiler

Apple MacBook Pro 16-inch, 2023 (personal)

  • M2 Max
    • 4 efficiency cores
    • 8 performance cores
    • 38-core Apple GPU
  • 96GB LPDDR5-6400
  • 8TB SSD
  • macOS 14 "Sonoma"
  • 16.2" 3456×2234 120 Hz mini-LED VRR display
  • Wi-Fi 6E + Bluetooth 5.3
  • 99.6Wh battery
  • 1080p webcam
  • Fingerprint reader

Also — iPhone 12 Pro 512GB, Apple Watch Series 8

 

Dell Precision 7560 (work)

  • Intel Xeon W-11955M ("Tiger Lake")
    • 8×2.6 GHz base, 5.0 GHz turbo, hyperthreading ("Willow Cove")
  • 64GB DDR4-3200 ECC
  • NVIDIA RTX A2000 4GB
  • Storage:
    • 512GB system drive (Micron 2300)
    • 4TB additional storage (Sabrent Rocket Q4)
  • Windows 10 Enterprise LTSC 2021
  • 15.6" 3940×2160 IPS display
  • Intel Wi-Fi AX210 (Wi-Fi 6E + Bluetooth 5.3)
  • 95Wh battery
  • 720p IR webcam
  • Fingerprint reader

 

Previous

  • Dell Precision 7530, 7510, M4800, M6700
  • Dell Latitude E6520
  • Dell Inspiron 1720, 5150
  • Dell Latitude CPi
Link to comment
Share on other sites

I seem to remember Linus doing a video very recently about this issue and that it was noticed by Microsoft.

  • Thumb Up 1

Desktop: Ryzen 5 5600X3D | 32 GB RAM | GeForce RTX 4070 Super | 4 TB SSD | Windows 11

MacBook Pro 14: M3 Pro 12-core CPU | 18 GB RAM | 18-core GPU | 1 TB SSD | macOS

Lenovo IdeaPad 3 Gaming: Ryzen 7 6800H | 16 GB RAM | GeForce RTX 3050 | 512 GB SSD | Windows 11

Lenovo IdeaPad 5 Pro: Ryzen 5 5600U | 16 GB RAM | Radeon Graphics | 512 GB SSD | Windows 11

 

Link to comment
Share on other sites

1 hour ago, saturnotaku said:

I seem to remember Linus doing a video very recently about this issue and that it was noticed by Microsoft.

Yeah, there's the video if anyone is interested:

https://www.youtube.com/watch?v=OHKKcd3sx2c

 

Both Windows 10 and 11 are affected by this issue. In some devices the issue was even more severe - like HP EliteBook 845 G8, which simply freeze instead of going in to sleep. HP released so called "System Default Settings" package to address this issue... The funny fact is, that package is available on 845 G7 drivers page instead of 845 G8, so many owners most likely missed it.

 

 

  • Thumb Up 1
Link to comment
Share on other sites

  • 2 weeks later...
On 1/31/2023 at 9:24 AM, Steerpike said:

I just saw this post while looking for other info on the site.  I did extensive work on 'standby' issues way back, and I seem to recall posting the info here somewhere but not sure where offhand.   Did you ever make progress with this?

I resorted to using hibernation. However, I follow the progress with this battle with interest.

Link to comment
Share on other sites

10 hours ago, John Ratsey said:

I resorted to using hibernation. However, I follow the progress with this battle with interest.

I got instability (couple of failures to boot) on my Samsung NP950 recently when I re-enabled S3, but my LG Gram continues to sport S3 with no issues.  So for now, I'm running one with S0, the other S3, and observing any differences. I have to say, so far, I'm not seeing any difference. I've never noticed the fan kicking in while in S0 on the Samsung. But - if I need to really put the laptop in a dormant state, I use hibernate on both and ... hibernate has become suitably fast for both entry and exit. 

Link to comment
Share on other sites

  • 2 weeks later...
On 2/14/2023 at 8:31 PM, MyPC8MyBrain said:

any of you tried unhiding "away mode" in power policy then setting it to "no" in active policy?
 

https://www.tenforums.com/tutorials/108441-add-remove-allow-away-mode-policy-power-options-windows.html

Intriguing ... never heard of it. Reading the article, it's not meant to be a power management option; but it sounds like it will save power by virtue of some of its actions, without entering sleep mode(s).  How do you 'invoke' 'away' mode - what's the user action? And does it actively prevent entry to sleep modes (while doing its own version of it)? 

Update - I just read some articles about it; by default, it seems the feature is only there if you have a 'presence sensor', which I don't (this is the article I read). If you have the presence sensor, and active the feature in settings, simply 'walking away' will engage 'away mode' it seems.  But is there some UI element you can use to say "I'm going away"? Or am I missing the point? 

Link to comment
Share on other sites

away mode is enabled by default and activated by countdown even without sensor presence,
the sensor will only give the signal to start countdown without it there is still an arbitrary away countdown,

to invoke it is to unhide it first

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\238c9fa8-0aad-41ed-83f4-97be242c8f20\25dfa149-5dd1-4736-b5ab-e8a37b5b8187]
"Attributes"=dword:00000002

 

and toggle it from advance power plan settings,

away.jpg 

 

personally i am not a fan of any delay when i move my mouse, my power setup is modern sleep off, hibernate off, and sleep is off, i only kept "turn off screen" after certain time left in its place, the system will go to S3 after the screen shuts off and that's plenty of standby saving (for me) without fully putting the system to hibernate or sleep,

the impossible is not impossible, its just haven't been done yet.

Link to comment
Share on other sites

3 hours ago, MyPC8MyBrain said:

away mode is enabled by default and activated by countdown even without sensor presence,
the sensor will only give the signal to start countdown without it there is still an arbitrary away countdown,

to invoke it is to unhide it first

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\238c9fa8-0aad-41ed-83f4-97be242c8f20\25dfa149-5dd1-4736-b5ab-e8a37b5b8187]
"Attributes"=dword:00000002

 

and toggle it from advance power plan settings,

away.jpg 

 

personally i am not a fan of any delay when i move my mouse, my power setup is modern sleep off, hibernate off, and sleep is off, i only kept "turn off screen" after certain time left in its place, the system will go to S3 after the screen shuts off and that's plenty of standby saving (for me) without fully putting the system to hibernate or sleep,

So you don't have any 'timer' or 'activity' based changes, other than screen off; and I presume you explicitly shutdown/hibernate/sleep when you want to do so?  Fair enough, that should avoid problems.  I presume you don't spend much time on battery?  

 

But what I'm still not getting is, how does 'away' interact with sleep?  It sounds like away mode is close to S0, but somehow different. Everything I'm reading is telling me how to enable it, but I'm not yet finding the article that gives me a pros/cons, side-by-side comparison between away and sleep. 

Link to comment
Share on other sites

i see away mode an attempt to replace classic sleep with a modern sensor based alternative,
these function still live side by side on recent win11 and active by default, i guess they will eventually expire one or hide it,

for most users this behavior is just fine and prob wanted, i prefer manual approach then auto gears to all aspects of my personal computing,

i never let the system sleep or hibernate and i don't ever shut it off its on 24/7/365, i do use it on battery it will last 5 hours watching youtube on my AC settings,

that is more then enough for me between charging, i was never a mac user so two week battery life is not expected from a powerful mobile laptop,
 

 

the impossible is not impossible, its just haven't been done yet.

Link to comment
Share on other sites

  • 3 weeks later...

Linus did a video awhile back on this very topic.  When plugged in, the device does not "sleep" per se, it just shuts off the screen etc.  When unplugged, it will properly sleep.  So if you need sleep, unplug first then goto sleep.  

Workstation - Dell XPS 8940 - desktop creative powerhouse

Mobile Workstation - Dell inspiron 5406 2 in 1 - mobile creative beast

Wifey's Notebook - Dell inspiron 3169 - Little gem for our businesses

Link to comment
Share on other sites

8 hours ago, kojack said:

Linus did a video awhile back on this very topic.  When plugged in, the device does not "sleep" per se, it just shuts off the screen etc.  When unplugged, it will properly sleep.  So if you need sleep, unplug first then goto sleep.  

Surely this would be configurable?  I can see what you describe above as being a typical default behavior, but can I not change it so that it would not sleep when unplugged, or conversely, to sleep when plugged?  I thought linux was tweakable in the extreme 🙂

Link to comment
Share on other sites

This is not linux.  Also, I am not sure of the reasoning.  Linus and crew deducted this is how windows sleeps. Different stages using different power delivery methods.  I think something is screwed up in the programming of said feature. 

Workstation - Dell XPS 8940 - desktop creative powerhouse

Mobile Workstation - Dell inspiron 5406 2 in 1 - mobile creative beast

Wifey's Notebook - Dell inspiron 3169 - Little gem for our businesses

Link to comment
Share on other sites

 

13 hours ago, kojack said:

Linus did a video awhile back on this very topic.

 

4 hours ago, Steerpike said:

I thought linux was tweakable in the extreme 🙂

 

I think maybe there is some confusion of Linus Torvalds (Linux guy) vs. Linus Tech Tips (YouTube channel / tech community)?

Apple MacBook Pro 16-inch, 2023 (personal) • Dell Precision 7560 (work) • Full specs in spoiler block below
Info posts (Dell) — Dell Precision key postsDell driver RSS feeds • Dell Fan Management — override fan behavior
Info posts (Windows) — Turbo boost toggle • The problem with Windows 11 • About Windows 10 LTSC

Spoiler

Apple MacBook Pro 16-inch, 2023 (personal)

  • M2 Max
    • 4 efficiency cores
    • 8 performance cores
    • 38-core Apple GPU
  • 96GB LPDDR5-6400
  • 8TB SSD
  • macOS 14 "Sonoma"
  • 16.2" 3456×2234 120 Hz mini-LED VRR display
  • Wi-Fi 6E + Bluetooth 5.3
  • 99.6Wh battery
  • 1080p webcam
  • Fingerprint reader

Also — iPhone 12 Pro 512GB, Apple Watch Series 8

 

Dell Precision 7560 (work)

  • Intel Xeon W-11955M ("Tiger Lake")
    • 8×2.6 GHz base, 5.0 GHz turbo, hyperthreading ("Willow Cove")
  • 64GB DDR4-3200 ECC
  • NVIDIA RTX A2000 4GB
  • Storage:
    • 512GB system drive (Micron 2300)
    • 4TB additional storage (Sabrent Rocket Q4)
  • Windows 10 Enterprise LTSC 2021
  • 15.6" 3940×2160 IPS display
  • Intel Wi-Fi AX210 (Wi-Fi 6E + Bluetooth 5.3)
  • 95Wh battery
  • 720p IR webcam
  • Fingerprint reader

 

Previous

  • Dell Precision 7530, 7510, M4800, M6700
  • Dell Latitude E6520
  • Dell Inspiron 1720, 5150
  • Dell Latitude CPi
Link to comment
Share on other sites

4 hours ago, kojack said:

This is not linux.  Also, I am not sure of the reasoning.  Linus and crew deducted this is how windows sleeps. Different stages using different power delivery methods.  I think something is screwed up in the programming of said feature. 

 

Well I can say with some certainty that this is not how windows works!  Sleep and 'screen off' are two different animals, and both are available when plugged in or on battery. 

4 hours ago, Aaron44126 said:

 

 

 

I think maybe there is some confusion of Linus Torvalds (Linux guy) vs. Linus Tech Tips (YouTube channel / tech community)?

OMG 🙂

Link to comment
Share on other sites

When you hit sleep on the power menu when you are plugged in your pc stays "awake" doing more processes in the background than when you hit sleep while unplugged.  Linus toravids and LTT are the same guy.   

 

Go watch the video....it explains their findings.  No, this is not how windows is supposed to work, but thats how it does for now, until microsoft fixed this small issue.  Once you know about it, unplug, then put the pc in sleep and it will sleep and not cook your backpack. 

Workstation - Dell XPS 8940 - desktop creative powerhouse

Mobile Workstation - Dell inspiron 5406 2 in 1 - mobile creative beast

Wifey's Notebook - Dell inspiron 3169 - Little gem for our businesses

Link to comment
Share on other sites

17 minutes ago, kojack said:

Linus toravids and LTT are the same guy

Linus Torvalds (Father of Linux OS) and  Linus Sebastian (LTT) are not the same person.

Linus Benedict Torvalds - https://en.wikipedia.org/wiki/Linus_Torvalds

Linus Gabriel Sebastian - https://en.wikipedia.org/wiki/Linus_Sebastian

 

 

14 hours ago, Steerpike said:

Surely this would be configurable?

it is, if the system is acting up with sleep power options simply uninstall and reinstall display driver.

the impossible is not impossible, its just haven't been done yet.

Link to comment
Share on other sites

Wow, learn something new.  I have seen LTT called LT.....

 

as for the sleep...GO WATCH THE VIDEO....

 

Here I will link it so you do have to hunt for it. 

 

It's not as simple as re installing a driver.  that's not the issue.  

 

 

Workstation - Dell XPS 8940 - desktop creative powerhouse

Mobile Workstation - Dell inspiron 5406 2 in 1 - mobile creative beast

Wifey's Notebook - Dell inspiron 3169 - Little gem for our businesses

Link to comment
Share on other sites

12 hours ago, kojack said:

When you hit sleep on the power menu when you are plugged in your pc stays "awake" doing more processes in the background than when you hit sleep while unplugged.  Linus toravids and LTT are the same guy.   

 

Go watch the video....it explains their findings.  No, this is not how windows is supposed to work, but thats how it does for now, until microsoft fixed this small issue.  Once you know about it, unplug, then put the pc in sleep and it will sleep and not cook your backpack. 

I'll watch the video. But we need to be more specific. Are you talking 'modern standby' (S0) or 'classic standby' (S3)?  I am generally discussing S3 sleep when I talk about 'sleep', but I am very much aware that 'modern standby' (S0) is designed to allow your computer to 'continue doing certain tasks' even when 'sleeping' - which I think is something of a travesty, but I know that's the design intent. But it's still not identical to 'screen off' when plugged in or not. 

 

Modern Standby is intended to allow certain 'conforming' apps to do a limited number of 'approved' activities while the computer is in S0 state.   I think this is a fundamentally bad design, and it makes S0 sleep 'almost like' screen dark, but there is a difference. When screen is dark (but computer is not in S0 state), anything and everything can keep running. But when computer goes to S0 'sleep', a number of tasks can continue but not all tasks.  There's a very detailed explanation somewhere that describes which tasks are allowed to continue, and under what circumstances. I know one such activity is downloading updates.  This article touches on some of the concepts but is not the definitive design document (but it illustrates the point): 

 

Quote from the article: 

"Many Microsoft Store apps use background tasks to update their live tile, generate toast or notifications, and sync data with the cloud. These same background tasks can run during modern standby."

 

Quote from the article: 

"Desktop applications are automatically paused by the Desktop Activity Monitor (DAM) after the system enters standby. The DAM suppresses desktop application execution in much the same way as the Sleep (S3) system power state in systems that support the traditional ACPI S3 and S4 states."

 

In short, I'd say that Modern Standby aka S0 sleep is much closer to 'screen dark' than S3 sleep, but is still not the same, regardless of whether plugged in or not.  Further - as much as I don't like it and think it's a bad idea, I do believe it is how Microsoft intend it to work so it's not a 'bug' per se. 

 

EDIT TO ADD: - my remedy on a system that has S0 / Modern Standby is to enable Hibernate and use Hibernate where I would have used S3 previously.  On one of my new laptops, I've successfully enabled S3 and disabled S0, but on another new laptop, S3 gave me problems so I just use hibernate. 

 

EDIT TO ADD: just watched the video. Pretty decent overall summary of the problem, but - on MY brand new Samsung NP950 Windows 11 / modern standby laptop, disconnecting the power does NOT change the status of S0 from 'Network Connected' to 'Network Disconnected' - I just tried it using powercfg /a, with/without power plugged in, and no change.  So - as I stated above - I have enabled hibernate, and set lid close to hibernate, and all my problems were solved. 

Link to comment
Share on other sites

I've been doing some measurements and calculations on my two 'modern' laptops (S0 capable) - LG Gram 17, 2021 edition (model 17Z95P), and Samsung NP950XDB.  The LG Gram is currently set for Classic Sleep (S3) and the Samsung is set for 'modern sleep' (S0, aka 'low power idle'). I'm doing this mainly in support of some battery pack evaluations that I'm documenting in this thread, but these observations are more relevant to this post. 

 

LG Gram, Classic Sleep. 

Last night my laptop entered S3 (classic standby) at 2:25:49 am, with the battery at charge level 79%. This morning I 'woke it' from sleep at 10:02:19 and the charge level was 76%.  This info is taken from 'Sleep Study Report' (cmd /k powercfg /sleepstudy /output c:\myfiles\SleepStudyReport.html /duration 28). 

 

image.thumb.png.37ba9eee83eac92b0439b9b89e6d1671.png 

 

This info is corroborated by BatteryInfoView: 

 

image.thumb.png.8e90cec57bf280b939ce36dd45b28498.png

 

As can be seen, the duration of S3 sleep was 7:36:30, and during that time, 3.4% of battery capacity was consumed. 7:36:30 = 7.608 hrs. 

If 7.608 hrs of sleep consumes 3.4%, then 100% should be 223.77 hrs (about 9 days). 

 

Looking for other 'standby' states in the 28 day log, I found one that was much longer (and should therefore yield more accurate numbers) - 

 

image.thumb.png.3a1dee632d3787ad62053c08b236495d.png

 

Over 37 hours of standby, and 14% of battery. Calculations for this session are - 37:33:28 = 37.56 hrs.  If 37.56 hrs of sleep consumes 14%, then 100% would be 268.27 hrs (about 11 days). 

 

So I would conclude from this that 'classic sleep' will last about 9-11 days on a full battery. 

 

Looking at my other 'modern' laptop (Samsung NP950XDB), which is configured for 'Modern Standby' (S0), I don't have any long Sleep sessions (as I've always used hibernate). So I will let it go into S0 sleep today and monitor it after about 8 hours and update this post. UPDATE 20-MAR-23) - I let my Samsung sleep for almost 24 hours, in S0 sleep. 

 

image.thumb.png.e5d1d99521572bdd03e6982b23dfd9be.png

 

23:22:21 is 23.37 hrs. If 10% battery is consumed in 23.37 hours, that suggests 100% will be consumed in 233.7 hours (about 10 days). This is not much less than classic sleep (though I am comparing different machines here; my Samsung has a lower capacity battery (67 Wh) compared to the LG (80 Wh), so the 'percentage of battery' values are not directly comparable). But for rough purposes, I think I can conclude here that S0 and S3 are not appreciably different. The bigger issue here is probably that S0 allows for a variety of activities to occur (downloads of updates, emails, etc) and those activities could, on any given day, be substantial.  What I really need to do is change my LG from S3 to S0 and do a more direct comparison but I'm not willing to do that right now. (end of update 20-MAR-23). 

 

Also a bit concerning is that even hibernate is consuming measurable power on this LG Gram; I have a log of a 10 hour hibernate session that consumed 1.9% of battery capacity.  Not a lot, but more than I think is appropriate for hibernate. I need to do some longer hibernates while on battery to get some better measurements.  I would have expected a 10 hour hibernate session to consume much less than 1% by a long way. (exact calculation is - 9:56:26 duration, 1.9% consumption, suggesting 100% would be about 21.8 days - not nearly long enough for hibernate, IMO). 

 

(I'll update this thread with some S0 measurements from my S0 laptop and also some better hibernate measurements). 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Terms of Use